<![CDATA[ Extras fail to update/install - MODX Community Forums]]> https://forums.modx.com/thread/?thread=103572 <![CDATA[Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557196
Bootstrap 1.0.28 -> 1.0.29 fails. The Console window pops up, and remains obstinately blank, and must be closed by killing the window - the Close button is greyed-out.

Bootstrap then claims to be uninstalled (no longer offering an update), but shows version 1.0.29 of Bootstrap.

I have tried:

Clearing the cache the MODX way
Clearing the cache - brute force - entire contents of /core/cache removed
Removing and reinstalling Bootstrap
Reinstalling MODX and repeating the above.

All to no avail.


Suggestions of where to go next?


Nic Boyde





MODX 2.6.1 • PHP 7.0.27]]>
nicboyde Mar 05, 2018, 06:42 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557196
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557353
For future reference, there's a technique described here that might have helped find the problem: https://bobsguides.com/blog.html/2013/05/22/debugging-cmps-a-horror-story/]]>
BobRay Mar 12, 2018, 08:57 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557353
<![CDATA[Re: Extras fail to update/install (Best Answer)]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557347
Modmore's fix at GitHub: https://github.com/modxcms/revolution/pull/13813

Full details there.

Big thank you to Mark Hamstra.]]>
nicboyde Mar 12, 2018, 07:33 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557347
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557258
Is there anything in the MODX error log?

]]>
BobRay Mar 07, 2018, 09:14 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557258
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557256
Permissions on the folders in which the packages reside? (Unlikely if you have successfully reinstalled MODX)

Have you recently moved any of your folders? ie: core/packages. If the config file was pointing to the old location this could cause it. (Again unlikely if you have successfully reinstalled MODX)

Can't think of anything else at the moment!]]>
andytough Mar 07, 2018, 06:37 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557256
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557252 Quote from: andytough at Mar 07, 2018, 05:26 PM
Do you have TinyMCE installed? I have occasionally encountered problems installing other packages when it is present.

I did Andy. I took it out first when I started trying to isolate the problem. It took several Remove Package instructions before it removed itself. Not that, I'm afraid.



Nic]]>
nicboyde Mar 07, 2018, 05:30 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557252
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557251 andytough Mar 07, 2018, 05:26 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557251 <![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557249 Quote from: BobRay at Mar 06, 2018, 09:24 PM
If that doesn't work, it probably means the 1.0.29 doesn't work in the current version of MODX or with your version of PHP.

Bob

We can eliminate that. I have cleaned out all the transport packages, the cache and reinstalled 2.6.1 on top of the existing database. The database has tables in it from former packages (QUIP et al) that were not removed when the package was uninstalled, but I can find no trace of any reference to Wayfinder, for example, in the database. This site is on PHP 7.0.27.

I then tried to install Wayfinder. No dice. Same symptoms. All extras fail to install. Something's badly broken. It isn't the extras. It has to be the database, no?

It may be relevant that I had MoreGallery 1.5.5 installed and an offered upgrade to 1.6.2 failed with these symptoms. Since then, no extra has been able to upgraded or installed.

Any more ideas, or am I looking at a full site rebuild?



Nic Boyde]]>
nicboyde Mar 07, 2018, 05:18 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557249
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557227
Same symptoms as the Bootstrap package. It ain't the Bootstrap package.

Now to reinstall, again, the whole shebang. I will report.]]>
nicboyde Mar 06, 2018, 10:29 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557227
<![CDATA[Re: Extras fail to update/install]]> https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557224
My best guess at a solution would be to uninstall and remove all versions of Bootstrap in Package Manager, check to make sure there are no vestiges in files or the DB, manually clear the cache, then download and install 1.0.29. If that doesn't work, it probably means the 1.0.29 doesn't work in the current version of MODX or with your version of PHP. BTW, If you're using PHP 7.2, I would back off to 7.1. before installing 1.0.29.]]>
BobRay Mar 06, 2018, 09:24 PM https://forums.modx.com/thread/103572/extras-fail-to-update-install#dis-post-557224