<![CDATA[ Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.', - MODX Community Forums]]> https://forums.modx.com/thread/?thread=103362 <![CDATA[Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556206
FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',

when running c:/xampp/htdocs/modx-2.6.1-pl/setup/index.html. Seemingly the same was asked 4 years ago at

https://forums.modx.com/thread/82455/trouble-installing-modx-rev

but received no response. There, the full lengthy error message is quoted. It is the same as mine.

The error message itself seems corrupted as it recites a variable name rather than a variable value (a valid php version). Besides, the alleged error seems not to exist as I have php 7.2.0. XAMPP and MODX are new downloads on a new laptop. Running phpinfo() says php-version is 7.2.0, json support enabled. localhost/phpmyadmin says "Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.0". Follwing the indications at

https://forums.modx.com/thread/?thread=99417

I set date.timezone=Europe/Berlin and restarted localhost. Same error.

Any idea what this is and what to do?

Thank you for your attention.

Best regards

Axel]]>
pfeiffer3f Jan 07, 2018, 10:08 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556206
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.', (Best Answer)]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556336 Quote from: BobRay at Jan 09, 2018, 11:13 PM
Since it's a local install I'm assuming that you didn't copy the files individually with FTP. That often results in missing or corrupted files.

The only other thing I can think of is something in the XAMPP configuration. Make sure the rewrite engine and PDO are enabled. Does PhpMyAdmin work on the MODX database?

It seemed that the localhost itself was corrupted. Sometimes it processed php files, sometimes not. Phpmyadmin was working, seemingly properly. So I deleted modx and xamppm downloaded all new, installed all new, and now it is running. I don't know what it finally was.

Thank you for your answers.

Best regards

Axel]]>
pfeiffer3f Jan 13, 2018, 11:06 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556336
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556279
If so you need to amend it to read as below with the speech marks around the location:

date.timezone = "Europe/Berlin"

]]>
andytough Jan 11, 2018, 05:39 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556279
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556251
The only other thing I can think of is something in the XAMPP configuration. Make sure the rewrite engine and PDO are enabled. Does PhpMyAdmin work on the MODX database?]]>
BobRay Jan 09, 2018, 11:13 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556251
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556235
Thank you for the time you take.

Best regards

Axel]]>
pfeiffer3f Jan 08, 2018, 11:37 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556235
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556233
FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',

when running c:/xampp/htdocs/modx-2.6.1-pl/setup/index.html. Seemingly the same was asked 4 years ago at

https://forums.modx.com/thread/82455/trouble-installing-modx-rev

but received no response. There, the full lengthy error message is quoted. It is the same as mine.

The error message itself seems corrupted as it recites a variable name rather than a variable value (a valid php version). Besides, the alleged error seems not to exist as I have php 7.2.0. XAMPP and MODX are new downloads on a new laptop. Running phpinfo() says php-version is 7.2.0, json support enabled. localhost/phpmyadmin says "Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.0". Follwing the indications at

https://forums.modx.com/thread/?thread=99417

I set date.timezone=Europe/Berlin and restarted localhost. Same error.

Any idea what this is and what to do?

Thank you for your attention.

Best regards

Axel]]>
pfeiffer3f Jan 08, 2018, 11:15 PM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556233
<![CDATA[Re: Installation problem: FATAL ERROR: ... You\'re using PHP version '.MODX_SETUP_PHP_VERSION.',]]> https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556210
Does the modx-2.6.1-pl directory contain the core, connectors, and manager directories?

Is this a clean, new install or a copy of a remote site?]]>
BobRay Jan 08, 2018, 05:24 AM https://forums.modx.com/thread/103362/installation-problem-fatal-error-you-039-re-using-php-version-039-modx-setup-php-version-039#dis-post-556210