On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Has this been logged as a bug? Will it be fixed in a new release? Is there a new release coming out soon?

    QM is the #1 reason that I still have 20+ sites on Evo and not Revo.

    • Quote from: banzai at Sep 02, 2014, 02:36 PM
      Try to enable/disable "Load jQuery in manager" and "Load jQuery in front-end" and try all combinations.

      Changing these settings, depending on the site and the template, I always solved my QM issues

      QM doesn't work with the default website which is baffling to me.... Can you share the combo that you got working?
      • Ok I wish I had made a step by step list I did not..but Here are some of the critical things lets try there first...
        Plugin Config fo QM heres the whole thing if you just want to add..

        &1=undefined;; &jqpath=Path to jQuery;text;assets/js/jquery-1.9.1.js &loadmanagerjq=Load jQuery in manager;list;true,false;false &loadfrontendjq=Load jQuery in front-end;list;true,false;false &noconflictjq=jQuery noConflict mode in front-end;list;true,false;false &loadtb=Load modal box in front-end;list;true,false;true &tbwidth=Modal box window width;text;80% &tbheight=Modal box window height;text;90% &hidefields=Hide document fields from front-end editors;text;parent &hidetabs=Hide document tabs from front-end editors;text; &hidesections=Hide document sections from front-end editors;text; &addbutton=Show add document here button;list;true,false;true &tpltype=New document template type;list;parent,id,selected;parent &tplid=New document template id;int;3 &custombutton=Custom buttons;textarea; &managerbutton=Show go to manager button;list;true,false;true &logout=Logout to;list;manager,front-end;manager &disabled=Plugin disabled on documents;text; &autohide=Autohide toolbar;list;true,false;false &editbuttons=Inline edit buttons;list;true,false;false &editbclass=Edit button CSS class;text;qm-edit &newbuttons=Inline new resource buttons;list;true,false;false &newbclass=New resource button CSS class;text;qm-new &tvbuttons=Inline template variable buttons;list;true,false;false &tvbclass=Template variable button CSS class;text;qm-tv

        But Among other things You will notice that I updated the path to query-1.9.1.js (the min JQ I just took out .min part , I was previously using I think 1.45, I read that MM relies on 1.9... so that may have played a step I did have to copy that .js to there...

        Plugin Execution Order: (relevant ones where both MM and Qm are called, I think...I added the "onBeforeDocFormSave: as a 'system event' to QM one of those... )


        And Finally My Template was already calling Jquery, Since I wasn't sure which version ..I just made sure it was the same as what MM and QM rely on. So in this case - again I may have even copied over..
        <script type="text/javascript" src="assets/templates/"YOURTEMPLATENAME"/js/jquery-1.9.1.js"></script>

        I hope this helps at least a bit.
        Ill check back at a later time to see if there is anything else I could share..

        • Thanks Dfx. I was able to get it working without the Modal box using your configuration and jquery-1.9.1.js and Load jQuery in front-end = false. Not ideal. I would prefer to have the Modal working as all my clients are used to it. I imagine with more tweaking I could get the Modal window working. I tried several combinations and could get the modal window to launch but couldn't see the form fields to edit the resource.

          My biggest gripe is that this should be working by default with the default website that comes with the installation of 1.0.14. sad

          • Quote from: DfX at Sep 02, 2014, 02:03 PM
            Thanks Gonna focus on the MM for a bit and also see if my tempalte has too many scripts that may be conflicting. However I do think QuickEdit is invaluable for many of my clients/friends. Its far easier to edit from the front end wits spots that have been designated for them as editable, but I concede it certainly is not a deal breaker..

            I think it is a deal breaker. It is the one feature that I've sold to so many clients.
            • Hi Taiyo- Yes it can be frustrating. Modal-as far as the overlay is nice to have. But at least its still accessible from the front end. And..it takes you back to the page one Save. I assume we are talking about the modxhost template. Quite a workhorse - we must admit its been around a few years and in this case there must be someting with mootools/jquery conflict.
              with a fresh template it seems to work with the overlay.

              BUT if you are using modxhost as a base...
              Try adding jquery version into the script call order- (before the mootols call) , perhaps call it from the template folder (just add it that templates js library.). IF you do this then you will want to set your
              QM PLUGIN CONFIG
              - JqueryNoConflict mode back to TRUE
              - and Modal Front end back to True

              Do this and it may work. I got it working that way - locally
              BUT unfortunately that set up does not work with a new template Im working on - (which I got the editor overlay working by doing opposite)

              Try it now and see if that helps.
              • Dfx,

                Thanks for pointing out that MODxHost uses mootools.... I'm a bit more optimistic that if I upgrade my 20+ sites to 1.0.14 I may still be able to use QM with full Modal overlay.

                Pretty sure I will run into other issues but I will give it a go and update here.

                Thanks again.
                • can you please update me if that worked? I too am getting ready to try to fix this on all my evo sites.

                    Red Toad Media - Web Design, Louisville KY
                    Hear me tweet: http://www.twitter.com/redtoadmedia
                    "Bring on the imperialistic condiments." - Rory Gilmore