On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Quote from: danya_postfactum at Feb 04, 2013, 06:12 AM
    That was AjaxManager. You should read installation instructions for AjaxManager.
    I guess there is still Ace plugin, wich tries to load ace class. Delete plugin manually.

    OK, that worked, thanks! I'm calm again.

    Also, I noticed that the save-buttons were not completely gone, but hidden behind the grey menu bar. Tinkering with chrome's developer tools will show them so that the site will not be completely useless until you find the error.
    • Is the Ace component currently ignoring the "which_editor" User setting?

      It seems that if a Resource has "Rich Text" enabled, Ace no longer activates when editing Resources. For my administrator user, I have a custom user setting for "which_editor" set to "Ace". The only way Ace works on Resources now is if "Rich Text" is turned off. However, for the other Admins that prefer TinyMCE, this breaks that for them.

      I was able to add a check for this in the "Ace" plugin "OnDocFormPrerender" case:

      BEFORE:
                  if ( $richText || in_array($classKey, array('modStaticResource','modSymLink','modWebLink','modXMLRPCResource'))) {
                      return;
                  }
      

      AFTER:
                  if ( ($richText && $modx->getOption('which_editor') != 'Ace' ) || in_array($classKey, array('modStaticResource','modSymLink','modWebLink','modXMLRPCResource'))) {
                      return;
                  }
      


      I have not thoroughly tested this, but can confirm that Ace is working again for Rich Text resources for users which implicitly set "which_editor" to use "Ace" other than just for editing Elements. (e.g. which_element_editor)

      NOTE: This is using Ace 1.3.3-pl on MODX 2.2.7-dev [ed. note: pixelchutes last edited this post 5 years, 1 month ago.]
        Mike Reid - www.pixelchutes.com
        MODx Ambassador / Contributor
        [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
        ________________________________
        Where every pixel matters.
      • just set use_editor system setting to Off
        • I know you saw this in my other thread Danya but I am curious if anyone following this thread is seeing this.

          Is anyone having a problem highlighting a word of code when double clicking on it?
            MODX...the Zen of CMS
            "Bight off more than you can chew and keep right on chewing."
          • Quote from: danya_postfactum at Mar 02, 2013, 11:14 PM
            just set use_editor system setting to Off

            Thanks, Danya. I have tried setting a User System Setting for "use_editor" (tried both "No" and "0") and still cannot get it to render when editing Resources?

            I have even tried logging out and back in, but
            $modx->getOption('use_editor')
            keeps returning "1". (This is enabled in the global System Settings, it doesn't seem to be honoring my User System Setting). Very odd.

            I presume there is no way to optionally toggle between Ace + TinyMCE on-the-fly then, correct? [ed. note: pixelchutes last edited this post 6 years, 1 month ago.]
              Mike Reid - www.pixelchutes.com
              MODx Ambassador / Contributor
              [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
              ________________________________
              Where every pixel matters.
            • guillaume.fontaine Reply #16, 6 years, 1 month ago
              When I try to install Ace add-on, it breaks my modx installation (Revo 2.2.6) : I have a white screen on the right part.

              Do you have an idea to install it ?
              • Please try to press Ctrl+F5. Provide more info: your browser, check whether /manager/ folder is writable and /manager/componets/ace/ folder exists. Open browser console(F12 or Ctrl+Shift+K)/
                • guillaume.fontaine Reply #18, 6 years, 1 month ago
                  The problem was here !

                  /manager/ and /manager/components/ folders should exist and writable [ed. note: guillaume.fontaine last edited this post 6 years, 1 month ago.]
                  • rainbowtiger Reply #19, 6 years ago
                    What I want to do is use TinyMCE as the editor for rich text in the Content area, but use ACE when "Toggle Editor" is clicked. Is that possible?
                    • danya_postfactum Reply #20, 6 years ago
                      rainbowtiger, It would be great, but currently is impossibly. I think the best solution would be ace plugin for CKEditor. But currently we have CodeMirror plugin only. You can find that here.