On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Greetings,

    MODX 2.2.2 / Articles 1.6.1-pl

    The same rich text TV when used on a non-Article template uses the defined rich text editor (in my case, TinyMCE). When the exact same TV is used in the Articles container template, the editor is a simplistic rich-text editor.

    Other types of TVs seem to be using the correct input method (pull-down, radio, etc.) when used on Articles container templates.

    Another poster - in a different forum -- is having the exact same problem, but I posted this here (sorry for the duplicate - hoping it'll be seen): http://forums.modx.com/thread/76677/articles-doesn-t-show-rich-text-template-variable

    Fix? Work-Around? Note: In my case, I want to use the same TV definition; don't want to make a special one for Articles unless truly a last resort; it's a part of a site-wide collection of TVs/snippet that I want to keep unified.
    • Yes. This is an issue for me as well. Could someone else verify they are not having this problem?

      Please see two attachments of the same TVs displayed 'normal' resource and an Articles container.

      Setup:
      - Revo 2.2.5
      - Articles 1.6.3
      - Standard OS X / MAMP
      • This happened to me once. What I noticed was that the resource that was connected to the TVs had the rte in the resource settings turned off. It seems that a TV with tv-type richtext will show this stripped down version of a text editor, when the resource that it is in has its rte turned off. I activated the rte for that resource, and in the TVs TinyMCE was back in full action.

        Maybe this helps?

          Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
        • Was anyone successfully able to get this to work?

          Ben, I tried your way in the Advanced Settings tab, and it had no effect on the TVs attached to the CONTAINER for the Articles, which is my chief issue.

          Seems like the RTE setting is only for the articles contained within and not the container itself.

          Still looking for a way to get my TinyMCE TV back to normal on the Container.

          jason
          • Hi,

            i'm experiencing the same behavior and not only in Articles resources but also in normal resources (however i'm using Articles as well) - TV of RichText type uses more simplistic version of RTE (tiny mce here as well) and only when resource is set to use RichText (in Settings tab) then also TV has full featured RTE.

            i think this is bug because for some resources i don't want Content to be Rich Text because there's e.g. getResources call in it but at the same time i want to have Rich Text for the same resource's TVs.

            i tried also to assign special property for such TV (in Tools -> Property Sets) but seems it's getting ignored ...

            hope there's some workaround for this.

            kr
              MODX Revolution 2.2.8-pl (advanced)

              Extras:
              archivist 1.2.4 | Articles 1.7.1 | Babel 2.2.5 | getpage 1.2.3 | getresources 1.6.0 | quip 2.3.3 | SimpleSearch 1.6.1 | taglister 1.1.7 | TinyMCE 4.3.3 | Wayfinder 2.3.3

              PHP Version 5.6.20-0
              MySQL Version 5.5.31
            • We are running into the same problem. A RichText TV uses the expected version of TinyMCE across the resources, but when use the same TV on an Article container resource, it defaults to a simpler version of TinyMCE for some reason.

              Modx 2.3.1-pl
              Articles 1.7.9-pl


              So, we switched to CKEditor 1.1.1-pl and it seems to be behaving as expected for the RichText TV BUT now the actual Content field on an Article container resource is also using the CKEditor unexpectedly. Previously, using TinyMCE, it was not considered a RichText field and was plain text. Weird.
              • Same issue here where rich text is turned off in the resource settings but is set on a TV.
                  Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
                • Revo 2.3.5
                  TinyWrapper 1.0.0 beta

                  Does anyone know if a solution has been found for this problem?

                  Like the previous poster, my content field can't use richtext which means my TVs aren't so rich.

                  Also, this setup worked fine with CKEditor but not so much with Tiny.

                  https://creativ.space [ed. note: todd.b last edited this post 4 years, 1 month ago.]
                    Todd
                  • The common belief is that the RTE setting on the resource should govern all RTE usage on the resource, this includes RichTVs.
                    It's like saying, if you have RTE off, why you looking for proper rich TV?

                    So, I don't think it is a problem at all, it is just the way things are.
                    As for Articles showing you any other version of TinyMCE for RichTVs when RTE is turned off, beats me.

                    If you are using TinyMCE_Wrapper, Articles should not show any form of TinyMCE for TVs when RTE is turned off for that resource.

                    What I am getting from this thread is that cake wants to be eaten and had at the same time, that is:
                    I have RTE disabled for this resource but I want RTE enabled for its children TVs?
                    This is a feature that will be added in next release of _Wrapper

                    At this time, you can turn content, intro, description RTEs off, and leave only TVs, but this affects all resources even those that have RTE enabled.
                      TinymceWrapper: Complete back/frontend content solution.
                      Harden your MODX site by passwording your three main folders: core, manager, connectors and renaming your assets (thank me later!)
                      5 ways to sniff / hack your own sites; even with renamed/hidden folders, burst them all up, to see how secure you are not.
                    • It seems the previous posters are using Articles, but I am not.

                      I don't know if that matters or not.

                      Todd
                      https://creativ.space
                        Todd