On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • sorry for late reply,

    yes I did and it's present. I even checked for the FormIt translations and they are all there too. With exactly the same names as i'm seeing at the frontend like mewolari mentioned.
    • I have exactly the same problem. I need the error messages translated into German. I see that the "de" lexicon is present in:
      core/components/formit/lexicon/de
      I added the code in my Template Formit call: &language=`de` and I get the message: formit.field_required

      Can anybody please help?
      Thanks in advance.
      • Still no one with a solution to this problem?
        • I dont use &language=`nl` anymore.

          What works perfectly for me is the following syntax for FormIt:

          [[!FormIt?
             &hooks=`spam,email,redirect`
             &emailTpl=`contactTpl`
             &emailSubject=`Bericht verzonden via contact-formulier website`
             &emailTo=`info@mywebsite.nl`
             &validate=`naam:required,
                email:email:required,
                bericht:required:stripTags`
             &redirectTo=`27`
          ]]


          Change following settings in System -> System Settings
          -locale nl_NL
          -cultureKey nl

          Good luck!
          • Just bumping this in case anyone has found a solution as yet?

            If I have no &language set in Formit, it works. If I set &language to `en` it works in English (obviously). Set it to anything else and it doesn't - I get the formit.field_required message.

            Any ideas?
            • I had same problem what I did is set these setting: system Settings > Core > Lexicon en Language --> cultureKey: nl and fe_editor_lang: nl. Now errormessages are in nl(dutch) without setting formit lexicon-settings.
                UI /UX designer + bit of Front-End Developer. Getting around with MODx Revolution
              • I am facing a similar error …
                The error message is always "Fieldname is required". I don't know where the "is required" comes from and how to change it.
                - there is 'de' translation in my lexicon
                - I translated the english version as well
                - locale settings are set to 'de' (locale and culture key)

                I even can't find 'is required" within my database. Any suggestions?
                • What is that message coming from? The Manager, or a FormIt form on the front-end?

                  Lexicons aren't in the database, they are files. The Manager lexicon files are found in core/lexicon, while extras like FormIt would have their own lexicon files in their core/components/extra-name directories.
                    Studying MODX in the desert - http://sottwell.com
                    Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                    Join the Slack Community - http://modx.org
                  • Look in core/components/formit/lexicon.

                    The string is in the default.inc.php files there. I don't know why FormIt is not using that file when you set &language=`de`. Looking at the FormIt class file code, it should definitely load that file based on the &language setting.

                    If not, you might try setting this in the FormIt snippet:

                    $modx->setOption('cultureKey', 'de');


                    or this in the FormIt class file:

                    $this->modx->setOption('cultureKey', 'de');

                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                    • Thanks for the answers. I fixed it in the PHP file – it was hard-coded into components/formitbuilder/model/formitbuilder/FormRule.class.php

                      I replaced the string in this file and it works. It was on the front-end, not the manager. But I am wondering why formIt doesn't load the string from the DB?!

                      I also tried to copy "$modx->setOption('cultureKey', 'de');" into my formIt snippets, but it will still loads it from the PHP file.