On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Yes, it does, but I’m out of steps. tongue

    Edit: just saw a reply I missed until just now about the manager session save path. I haven’t changed the default to the manager as I wasn’t sure if this would affect security. Can I change it to the same folder that stores the web user session cookies? Is so, I’m guessing (hoping) that this will fix the problem.
    • Where, exactly, did you have the php.ini file that you modified? Is this the main server php.ini file, or a custom file in a directory?

      (although since it still recognized the manager login I don’t think that would be the problem in any case)
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • See my edit above.

        The only php.ini session saves I’ve altered are for the web user, so the one at the public_html level and the one under the weblogin snippet.

        I also tried adding it to the manager/media/browser/mcpuk/connections/php/ directory in an act of desperation but nothing altered.
        • You don’t need it in the weblogin snippet’s directory; it’s only needed where a .php file is executed from, and that’s in the root and in /manager, since everything else is included and run via the index.php files in those two directories.

          I’m setting up a local dev installation to see what I can see...
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
          • Ahhhh, it’s not in /manager.

            I’ll move a copy of it in there now and let you know.
            • Oh dear, well I didn’t break the website, but I have some error messages instead of a manager window. Looks like a clash with config.inc.php:

              Warning: session_start() [function.session-start]: open(../sesstmp/sess_vr3jh8tc52i8pivndb6usihlh1, O_RDWR) failed: No such file or directory (2) in /public_html/manager/includes/config.inc.php on line 60

              Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /public_html/manager/includes/config.inc.php:60) in /public_html/manager/includes/config.inc.php on line 60

              Warning: Cannot modify header information - headers already sent by (output started at /public_html/manager/includes/config.inc.php:60) in /public_html/manager/includes/config.inc.php on line 74

              Warning: Cannot modify header information - headers already sent by (output started at /public_html/manager/includes/config.inc.php:60) in /public_html/manager/index.php on line 169

              Warning: Unknown: open(../sesstmp/sess_vr3jh8tc52i8pivndb6usihlh1, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

              Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (../sesstmp) in Unknown on line 0

              • ...that’s breaking into new territory of I really have no clue how to fix this...
                • Anyone?
                  • Okay, even with just that one line in my php.ini file to alter the session save path, MODx manager login was throwing up those error messages.

                    So, I removed php.ini and added this just before the StartCMSSession call in manager/includes/config.inc.php

                    session_save_path("/sesstmp");

                    ...and that didn’t work either. It’s still saying the folder doesn’t exist. Is my syntax wrong? Error message says:
                    session_start() [function.session-start]: open(/sesstmp/sess_tuvejlj81hrm1tursnaqofqbn3, O_RDWR) failed: No such file or directory (2) in /home8/ecl/public_html/manager/includes/config.inc.php on line 63
                    • Try putting the set_session_path inside that function, just before its session_start() function call.
                              session_name($site_sessionname);
                              session_save_path('/full/path/to/session/files');
                              session_start();
                      

                        Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org