On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I am trying to work through Quip. (I had these issues with 2.0.0, so I tried uninstalling and installing 1.2.5 manually, but get the same issues.)

    I did try flushing permissions and logging back in.

    I created a few comments, one as Anonymous, two as Admin. I have several things going on that are wierd.

    1. When I am in the manager and go to Components -> Quip, the Threads tab says ’Access denied.’
    2. The other tabs don’t show the comments I added.
    3. When I go to the blog post page as an Anonymous user, it says ’Comments (3)’, but doesn’t show the comments. There is an empty space there as if the comments are taking up space, but they don’t display. I view the source code and they seem to be there, but don’t show. (see below) I can see them when logged in as Admin. Should the comments even be counted if I haven’t approved them yet?
      You may or may not want to use the code I write. It's probably all against the syntax rules of php and MODx. smiley

      Carpet Cleaning
    • Quip requires MODX 2.0.6 or later.
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
      • Sorry, I meant I tried Quip 2.0.0 and Quip 1.2.5.

        I’m on Revo 2.0.7.

        Additional note: It actually says ’Access denied.’ for tab that loads first when I go to Components -> Quip.
          You may or may not want to use the code I write. It's probably all against the syntax rules of php and MODx. smiley

          Carpet Cleaning
        • I figured out why the posts were being published immediately. I hadn’t added &moderate=`1` to my QuipReply snippet call. (When all else fails read the instructions, right?)

          So I added a comment that is awaiting approval, I just can’t see any posts in the back-end, yet. So I have no way to delete or approve comments.

          The comments aren’t appearing on the front-end in IE 7 when I have &useGravatar=`1`.
            You may or may not want to use the code I write. It's probably all against the syntax rules of php and MODx. smiley

            Carpet Cleaning
          • Okay figured out why the comments weren’t showing.

            The fact that a float was on the image too caused it to move somewhere funny.

            So when I commented out float: right; in the file /assets/components/quip/css/web.css, the comments showed up.

            (It may be just my page layout, but that is what fixed it. For my page layout, I had to make &gravatarSize=`45` to make it look pretty, so thank you for programming that in.)

            silly IE 7
              You may or may not want to use the code I write. It's probably all against the syntax rules of php and MODx. smiley

              Carpet Cleaning
            • Any word on why it would say ’Access denied.’?
                You may or may not want to use the code I write. It's probably all against the syntax rules of php and MODx. smiley

                Carpet Cleaning
              • Same problem here. Using 2.0.7-pl
                "Access denied" and "No data to display" after posting comment.

                Here’s my code (from the instructions - I want comments on same page as original post):

                <div id="content" class="blog-post">
                <h2 class="title"><a href="[[~[[*id]]]]">[[*pagetitle]]</a></h2>

                <p class="post-info">
                Posted on [[*publishedon:strtotime:date=`%b %d, %Y`]] |
                Tags: [[*tags:notempty=`[[!tolinks? &items=`[[*tags]]` &key=`tag` &target=`38`]]`]] |
                <a href="[[~[[*id]]]]#comments" class="comments">
                Comments ([[!QuipCount? &thread=`blog-post-[[*id]]`]])
                </a>
                </p>

                <div class="entry">
                <p>[[*introtext]]</p>
                <hr />
                [[*content]]
                </div>

                <div class="postmeta">
                [[*tags:notempty=`
                <span class="tags">Tags: [[!tolinks? &items=`[[*tags]]` &key=`tag` &target=`38`]]</span>
                `]]
                <br class="clear" />
                </div>
                <hr />
                <div class="post-comments" id="comments">[[!Quip?
                &thread=`blog-post-[[*id]]`
                &replyResourceId=`[[*id]]`
                &closeAfter=`0`
                ]]



                [[!QuipReply?
                &thread=`blog-post-[[*id]]`
                &notifyEmails=`kirk@gsyha.org`
                &moderate=`1`
                &moderatorGroup=`Moderators`
                &closeAfter=`0`
                ]]
                </div>
                </div>
                • Installed latest version of Quip and problems are resolved. I had added Moderators group with Admin as member prior to upgrading - I assume I need this group?
                  • I’m now on Quip 2.0.1 pl now and still am showing ’Access Denied’. Is there some permission setting that I should be making/changing?
                      You may or may not want to use the code I write. It&#39;s probably all against the syntax rules of php and MODx. smiley

                      Carpet Cleaning
                    • I found in the Security settings that there was a new Access Policy for Quip so this is what I did.

                      Security -> Access Controls -> User Groups -> edit Administrator group
                      Context Access -> Add Context
                      -context: mgr
                      -min role: 0
                      -access policy: QuipModeratorPolicy
                      Save
                      Save


                      Security -> Access Controls -> Access Policies -> edit QuipModeratorPolicy
                      check quip.thread_remove
                      Save


                      Security -> Flush All Sessions -> Yes
                      Log back in


                      Components -> Quip


                      I now see the comments, but there is still something wierd going on. (This may be a bug, it may not be. If it is, let me know and I’ll report it.)

                      The Wierd Going Ons:
                      -Unapproved Comments Tab
                      -- I don’t see the comments that are unapproved
                      -- I sometimes see one search box in the upper right and two search buttons
                      -Latest Comments Tab
                      -- I sometimes see a search box, a search button, and then another search box

                      See the attachment (if it works):
                        You may or may not want to use the code I write. It&#39;s probably all against the syntax rules of php and MODx. smiley

                        Carpet Cleaning