On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • At this time prototypify.js has not been added in all mutate_xxx.dynamic.php. So EditArea plugin doesn’t work for Chunks, Templates and Documents sad Hope this wil be done soon... wink
      Ackwa - Web Design & Development agency | Tours - France | Follow me on Twitter...
    • Prototypify.js has been removed in Rev. 2001 huh So, at this stage the current version of the Plugin doesn’t work anymore sad Thus you will find hereafter a slightly modified version of the pluggin ;-) With a little hack inspired from prototypify, this version now support the Prototype.js inclusion.

      Edit : The last version is here : http://modxcms.com/forums/index.php/topic,8285.msg65110.html#msg65110
        Ackwa - Web Design & Development agency | Tours - France | Follow me on Twitter...
      • @Gildas,

        As soon as I actually realized that it wasn’t working for templates, etc, I come here to find that you’ve posted the updated plugin code! Great work.

        I’m not sure why, but EditArea area seems to load much faster now, whereas before I was noticing a slight delay. laugh
          Mike Reid - www.pixelchutes.com
          MODx Ambassador / Contributor
          [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
          ________________________________
          Where every pixel matters.
        • We should see about getting this sucker into the Repository! Any chance we could utilize the Resource Wizard, too? haven’t tested with that, myself.
            Mike Reid - www.pixelchutes.com
            MODx Ambassador / Contributor
            [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
            ________________________________
            Where every pixel matters.
          • I will try to get this into a MODx Resource Wizard modxpkg.zip today.

            -sD-
              Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
              All of the above... in no specific order.


              I send pointless little messages
            • If one of the plugin authors would like to try this out and then post this in the repository, that would be awesome.
              Here it is.

              -sD-
                Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
                All of the above... in no specific order.


                I send pointless little messages
              • I’ve not yet install/try your MODx Resource Wizard. I will correct this "unforgivable mistake" right now wink ...
                  Ackwa - Web Design & Development agency | Tours - France | Follow me on Twitter...
                • @sD-

                  Unfortunately, I was not able to test the install package, because my install of Resource Wizard failed! lipsrsealed

                  I am on a testing server [public/external internet] where my MODx directory is a few directories deep. The resource wizard *did not* install, not to mention failed numerously on many unlink calls (trying to self-clean up the /install).

                  Also, the redirect to /manager was incorrect huh (appears to assume Base is /)

                  /************************************************
                  FINISH THE INSTALLATION
                  ************************************************/
                  case 'finish':
                  $url = "http://".$_SERVER['SERVER_NAME']."/manager/";
                  


                  Errors when trying to run the module:

                  Warning: Unknown(/www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php): failed to open stream:
                  No such file or directory in /www/mysubdir/modx_base_dir/manager/processors/execute_module.processor.php(95) : eval()'d code on line 8
                  


                  Where did the files go huh
                    Mike Reid - www.pixelchutes.com
                    MODx Ambassador / Contributor
                    [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
                    ________________________________
                    Where every pixel matters.
                  • I have been reading on this thread (MRW Support Thread) and was able to manually install MRW by uploading the missing /wizard directory.

                    This is what I receive when I test your MRW EditArea package:

                    Evaluation of your resource.
                    Warning: move_uploaded_file(/www/mysubdir/modx_base_dir/assets/modules/wizard/eval/EditArea.0.1.4.modxpkg.zip): failed to open stream: Permission denied in /www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php on line 120
                    
                    Warning: move_uploaded_file(): Unable to move '/tmp/phpOUPf60' to '/www/mysubdir/modx_base_dir/assets/modules/wizard/eval/EditArea.0.1.4.modxpkg.zip' in /www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php on line 120
                    The MODx Resource Wizard package could not be uploaded to the server.
                    


                    CHMOD /wizard/eval to 0777 allowed me to bypass this error!


                    "Edit Area" version 0.1.4 beta:
                    Ready to install the "Edit Area" plugin.

                    Press Continue to proceed and the plugin will be written to the database.
                    Press Cancel to stop the installation and remove all uploaded files.


                    So, I pressed continue only to see:

                    Your plugin has been installed.

                    Yet still...
                    
                    Warning: file_get_contents(/www/mysubdir/modx_base_dir/assets/plugins/edit_area/edit_area.plugin.txt): failed to open stream: No such file or directory in /www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php on line 285
                    
                    Warning: wizard_install(/www/mysubdir/modx_base_dir/assets/plugins/edit_area/install.php): failed to open stream: No such file or directory in /www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php on line 286
                    
                    Fatal error: wizard_install(): Failed opening required '/www/mysubdir/modx_base_dir/assets/plugins/edit_area/install.php' (include_path='/www/mysubdir/modx_base_dir/manager/includes/') in /www/mysubdir/modx_base_dir/assets/modules/wizard/wizard.class.php on line 286
                    



                    Apparently, /assets/plugins/edit_area never was created... Argh...

                    CHMOD /assets/plugins to 0777 allowed me to bypass this error!

                    Your plugin has been installed.... Only it doesn’t work. Enough hacking, this is starting to feel MESSY! (Not your fault)

                    Turns out, files were owned by Nobody, preventing it from working as expected. Also, the Plugin name was "Edit Area", not "EditArea" ... Once I uploaded the files (as root) it did NOT work until I renamed the plugin to "EditArea" (no space)

                      Mike Reid - www.pixelchutes.com
                      MODx Ambassador / Contributor
                      [Module] MultiMedia Manager / [Module] SiteSearch / [Snippet] DocPassword / [Plugin] EditArea / We support FoxyCart
                      ________________________________
                      Where every pixel matters.
                    • Quote from: Scotty at Nov 13, 2006, 06:04 PM

                      If one of the plugin authors would like to try this out and then post this in the repository, that would be awesome.
                      Here it is.
                      @sD

                      I am on a testing server with WAMP5 (http://www.wampserver.com). Sorry wink Like Pixelchutes my MODx directory wasn’t at the root and the redirect was incorrect. But nevertheless the installation of Ressource Wizard succeed. After this fisrt step I try to install the EditArea package. At this stage I had a problem with the "resource_pkgmime". On WAMP5 I have to change the test from "application/zip" to "application/x-zip-compressed". With this correction, all work fine wink This "install test" helped me to detect & correct an error in the plugin (@see http://modxcms.com/forums/index.php/topic,8285.msg63030.html#msg63030)...

                      NB : - The notes.txt is incomplete and due to CR problem unreadable (@see attachement).
                      - For the next version I will try to make a clean distribution of EditArea JS code...

                        Ackwa - Web Design & Development agency | Tours - France | Follow me on Twitter...