On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • No Probs Tim,

    Since using MODx we have never looked back its a great cms smiley
      http://www.onesmarthost.co.uk
      UK MODX Hosting with love.
    • Hi, I’m working with IIS7, Vista, firstly for testing and i have followed exact instructions as mentioned but not successfull. I have installed ISAPI Lite version and modx installed on main root wwwroot and i can view modx site using url: localhost, no sub folder, It is main root. But not successful, i am fedup with these friendly URLs i have tried everything but doesn’t work at all. Getting following errors:


      Server Error in Application "Default Web Site"
      HTTP Error 404.0 - Not Found

      Description: The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

      Error Code: 0x80070002

      Notification: MapRequestHandler

      Module: IIS Web Core

      Requested URL: http://localhost:80/geting-help.html

      Physical Path: C:\inetpub\wwwroot\geting-help.html

      Logon User: Anonymous

      Logon Method: Anonymous

      Handler: StaticFile

      Most likely causes:

      * The directory or file specified does not exist on the Web server.
      * The URL contains a typographical error.
      * A custom filter or module, such as URLScan, restricts access to the file.

      What you can try:

      * Create the content on the Web server.
      * Review the browser URL.
      * Create a tracing rule to track failed requests for this HTTP status code and see which module is calling SetStatus. For more information about creating a tracing rule for failed requests, click here.

      More Information... This error means that the file or directory does not exist on the server. Create the file or directory and try the request again.
      Server Version Information: Internet Information Services 7.0.


      Any help !

      Ta
      • It is working with me in slightly diffrent way but almost same as posted by Aaron, Thanks for the post Aaron.

        The way i worked is:
        IIS7, ISAPI Rewrite 3 Lite, 404, 405
        --------------------------------

        1- Installed ISAPI Rewrite 3 Lite on IIS7 (Refer to the relevant installation notes)
        2- in my case i have redirected the 404/405 error pages to index.php
        3- Open ISAPI Rewrite 3 Lite installation folder (in my case i have installed in C:\Program Files\Helicon\ISAPI_Rewrite)
        4- Open httpd.ini and copy and paste the following code (provided in the post: http://modxcms.com/forums/index.php/topic,10915.msg81058.html#msg81058)

        Code:

        [ISAPI_Rewrite]
        # 3600 = 1 hour
        CacheClockRate 3600

        RepeatLimit 32
        # Block external access to the httpd.ini and httpd.parse.errors files
        RewriteRule /httpd(?:\.ini|\.parse\.errors).* / [F,I,O]

        # Block external access to the Helper ISAPI Extension
        RewriteRule .*\.isrwhlp / [F,I,O]

        RewriteEngine On
        RewriteCond Method GET|HEAD

        RewriteRule /(?!(?:manager|assets)/)(.*)\.html(?:\?(.*))? /index.php?q=$1?2&$2: [I,L,U]

        5- Save this file, if you can’t save the file and get error then Go into httpd.ini file Properties and UNCHECK from Readonly and then save.

        6- Now Log into MODx manager -> Click Administration -> System Configuration -> Friendly URL Settings

        My Settings are:

        Use Friendly URLS = yes
        Prefix for friendly URLS =
        Suffic for friendly URLS = .html

        This is what i have done and its working now. Remember Modx installation is in root folder wwwroot.

        I have done this using the help of this post : http://modxcms.com/forums/index.php/topic,10915.msg81058.html#msg81058 by Aaron Wardle. Thanks Aaron.

        Regards,

        Sami
        • Those instructions worked for me with one exception: the variables in the url querystring are being ignored.

          For instance, the variables within this URL:
          http://mysite.com/members.html?service=viewprofile&username=mcclausky are ignored, it’s like IIS would always load just http://mysite.com/members.html

          This causes some features (snippets) like SearchHighlightning, and WebLoginPE to not work properly.

          Any ideas on how to solve this please?

          Thank you.
          • http://www.experts-exchange.com/Programming/Languages/Scripting/Q_23463918.html (scroll down past all the advertising links to see the responses).

            From this it looks like you would need to get the _SERVER["REQUEST_URI"] and parse that to get the query string.

            I would think a plugin would be best for this; just use the plugin code to extract the key->value pairs, and load them into the $_GET array so the snippet and other MODx processing could proceed as usual.

            A snippet called at the beginning of your template would also do the job.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
            • thanks for your suggestion

              keyword
              • I’m desperate to get FURLs working with my modx site.

                I’m on IIS6, have installed ISAPI_rewrite 3 (full version, free for 45 days) and followed the instructions shown above. Initially I was getting a syntax error, but someone from the ISAPI forum informed me that the code I was using was for ISAPI v2, and not v3. He re-wrote it for me in v3, but this still doesn’t work.

                I’m getting close to giving up now sad

                Could someone please, please help me out?!

                Thanks
                • Don’t know if it will help but below is my .htaccess file from a MODx install on an IIS 6 server running ISAPI v3
                  RewriteEngine On
                  RewriteCompatibility2 On
                  RepeatLimit 32
                  RewriteBase /
                  
                  RewriteRule ^/httpd(?:\.ini|\.parse\.errors).*$ / [NC,F,O]
                  RewriteRule ^.*\.isrwhlp$ / [NC,F,O]
                  
                  RewriteRule ^/(?!(?:manager|assets)/)(.*)\.html(?:\?(.*))?$ /index.php?q=$1?2&$2: [NC,L,U]
                  
                  RewriteCond %{HTTP_HOST} .
                  RewriteCond %{HTTP_HOST} !^www\.your-domain\.co\.uk [NC]
                  RewriteRule (.*) http://www.your-domain.co.uk/$1 [R=301,L] 
                  RewriteRule ^index.html$ / [NC,R=301]
                  • Hi Bunk,

                    Thanks again for trying to help me out.

                    I know that I’m getting closer, as before I just pasted your script into my .htaccess and it altered my domain to ’yourdomain’! I quickly altered this to my domain, and although it changed back, I’m still having problems with the FURLs. What are your configuration settings in modx? Or shouldn’t this matter?

                    Can you think of anything else I maybe missing?

                    Thanks
                    • SEE ATTACHED SCREEN SHOT