We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40088
    • 708 Posts
    Revo 2.4.2

    After upgrading to v2.4.2 (from 2.4.1) I'm unable to save Property Sets or System Ssettings.

    When clicking "Save Property Set" (or Save) two things happen:

    • The save process hangs.
    • The bottom part of the Manager page goes completely white, almost like the page stalls in the middle of reloading.
    The only way to fix it is to manually reload the browser window but of course the changes are not saved.

    In the case of System Settings the changes simply revert to their previous settings. No odd window behavior.

    Saving other things like Resources, Chunks and so on seems fine.

    I have an exact duplicate of the site with one exception: It uses 2.4.1 and everything works as expected. I've re-run the installer several times but nothing has helped. [ed. note: todd.b last edited this post 10 years, 11 months ago.]
      Todd
      • 3749
      • 24,544 Posts
      Try this (if you haven't already):

      -- log out
      -- manually delete all files in the core/cache directory
      -- clear your browser cache and cookies, or use private or incognito mode in your browser
      -- log back in.

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 40088
        • 708 Posts
        No luck.

        Since this is a client site I need a workaround if I can't fix it properly right now. Could I manually change the settings directly in the db or is that a bad idea all around?
          Todd
          • 3749
          • 24,544 Posts
          There's no harm in doing it in the DB, but be careful with the property sets, because they're JSON strings and need to remain valid.

          You may have a corrupted or missing file in MODX (unless it's a bug in that version, in which case you should see others reporting the same thing).
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 40088
            • 708 Posts
            Quote from: BobRay
            You may have a corrupted or missing file in MODX (unless it's a bug in that version, in which case you should see others reporting the same thing).

            If it were a corrupted or missing file then wouldn't it be overwritten (i.e. fixed) when I went through the entire update process (several times)?
              Todd
              • 3749
              • 24,544 Posts
              Yes it would. I don't know what else could cause that. The only thing that comes to mind would be mod_security, but it's very unlikely that it would affect all System Settings and all Property Sets.

              I guess a plugin that works in the Manager could do it, but that seems unlikely as well.

              You might try repairing all tables in the DB.

              I assume that there's nothing useful in the MODX error log -- you might look at the server's error log.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 40088
                • 708 Posts
                Quote from: BobRay
                You might try repairing all tables in the DB.
                How does one do that?

                Quote from: BobRay
                I assume that there's nothing useful in the MODX error log -- you might look at the server's error log.
                Most of the errors involve the manager:

                [2015-10-14 04:14:52] (ERROR @ /manager/index.php) Path specified for package articles is not a valid or accessible directory: /core/components/articles/model/
                [2015-10-14 04:14:52] (ERROR @ /manager/index.php) Could not load class: pdoParser from pdoparser.
                [2015-10-14 04:14:52] (ERROR @ /manager/index.php) Problem getting service parser, instance of class pdoParser, from path /core/components/pdotools/model/pdotools/
                [2015-10-14 04:14:52] (ERROR @ /manager/index.php) Could not load class: pdoParser from pdoparser.
                [2015-10-14 04:14:52] (ERROR @ /manager/index.php) Problem getting service parser, instance of class pdoParser, from path /home/princeto/core/components/pdotools/model/pdotools/

                The remaining errors involve the setup.
                  Todd
                  • 3749
                  • 24,544 Posts
                  You might try repairing all tables in the DB.

                  How does one do that?

                  Go into PhpMyAdmin (via cPanel)
                  Select the MODX database
                  At the bottom of the grid click on "Check All" to select all tables
                  Then use "With Selected" -> Repair Table to repair them.

                  The errors suggest that you might have a permissions issue with core/components.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 40088
                    • 708 Posts
                    After posting this on GitHub @sottwell replied with useful suggestion: mod_security.

                    I completely disabled mod_security in cPanel and it did solve the saving issue. However, I'm not comfortable leaving mod_security off.

                    Susan did mention there is a new mod_security ruleset that is known to cause issues with saving. I would like to contact the web host to see if that particular ruleset could be disabled on a shared server (I doubt it but it's worth asking about) but I don't know what ruleset it is.

                    Does anyone know?
                      Todd
                      • 3749
                      • 24,544 Posts
                      With a good host, they will sometimes check the logs to see which rules are being violated and turn off just those rules.

                      Another option is to disable mod_security for just the Manager directory.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting