We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28836
    • 13 Posts
    Hi
    We can not log in to the manager page since a php-update to 5.4.33

    We always get the following error message - no matter if we use correct or false login data:
    The username or password you entered is incorrect. Please check the username, re-type the password, and try again.

    Environment:

    • Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8m PHP/5.4.33
    • MySQL-Client-Version: 5.1.41
    • MODX Revolution 2.3.1-pl (traditional)

    What can I do to get the system back to work? The "workaround" to order a new pw each time we want to access the manager ist not our favorite way to work ;-)

    Cheers
    summerson


      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Try re-uploading the files and running the upgrade setup again. Make sure that all of the files have been merged. And of course the usual clearing of the MODX cache and your browser cache and cookies for the domain.

      You might want to change the default session handler in the System Settings to the PHP default (I think if it's just left empty it'll use the PHP default file system); the problem could be in the PHP/MySQL connections. Check the PHP date_timezone setting, the new PHP may not be configured correctly.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 28836
        • 13 Posts
        Hi sottwell

        I uploaded the files and ran the setup again ... including cache/cookie clearing that made it even worse :-(

        I now have the following situation:
        - I can login and don't have to order an new pw each time I want to login
        - I still can not chance a pw (none of the ways in my entry post works)

        What changed:
        The webpage showes now a white page without error messages or content to all visitors
        The manager is almost working: I can not choose a resource in the left menue to be shown and worked with on the right page. I only get a white page. But: I can change content pages by clicking the right mouse button and choose "Fast change": The popup appears and works...

        What I already tried:
        Delete all files (exept config.ini.php), deleting all db entries for the extras, installing everything new: No change ...

        Is there maybe an error log in modx I can have a look?



        Any help for me?
          • 3749
          • 24,544 Posts
          Try turning off the compress_js and compress_css System Settings in the modx_system_settings table in the database.

          Then delete all files in the core/cache directory before logging in.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 28836
            • 13 Posts
            Short: Noching changed...

            I opened the db and set both values (compress_js and compress_css) to "0", cleared the cache (also in the browser) but nothing changed.

            - The Website is still a white page
            - I can login to the manager but still can not change any passwords
            - I can expand the trees but not open any entry of "resources" or "elements" in the left navigation
            - The filemanager of the left navigation works fine - I even can open and work with .css files etc.

            additionally:
            Our provider checked the php config (date_timezone, ...) that should be OK, I also tried sottwells hint to change the default session handler...

            helplessly
            summerson
              • 3749
              • 24,544 Posts
              See if there's anything in the MODX error log in core/cache/logs.

              If everything else fails, you could ask the host to revert the PHP update.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 28836
                • 13 Posts
                Hi...

                An update to php Version 5.6.0 solved almost all problems.
                Now this is left:

                1. I still can not change passwords.

                  • If I go to manage-->users I can change/let create the password and it will be shown/emailed. None of it works.
                  • If I go to [username]-->user account on the right top menu to change the password, I get an error in the field "old password" - no matter if I fill in the correct one, the one modx created or a fake password.
                2. I can not create a new user and give him a pw - that will lead to the error in my entry post
                3. MAYBE IMPORTANT: If I use the "Forgot your Login?" link to recive a new pw now, I recive a password that will work (with each account and without limitations) - but that I also can not change...

                Here is an output of the error log while trying to change a password:
                [2014-10-07 16:17:08] (ERROR @ /connectors/index.php) Could not get table class for class: modAccess
                [2014-10-07 16:17:08] (ERROR @ /connectors/index.php) Could not get table name for class: modAccess
                [2014-10-07 16:17:08] (ERROR @ /connectors/index.php) Error 42000 executing statement: 
                Array
                (
                    [0] => 42000
                    [1] => 1064
                    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AS `modAccess` WHERE `modAccess`.`principal` = 8' at line 1
                )


                Thanks for the help
                summerson
                  • 3749
                  • 24,544 Posts
                  First, check that all the permissions are checked in the Administrator Policy and make sure that's the Policy in your Administrator User Group Context Access ACL entry.

                  If that's not it, try deleting all files in the core/cache directory and repairing all tables in PhpMyAdmin. Then use your browser's incognito or private mode to log in. If that solves it, clear your browser cache and cookies again.





                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 28836
                    • 13 Posts

                    • All the permissions are checked in the Administrator Policy: 172 of 172
                    • It is the Policy in our Administrator User Group Context Access ACL entry
                    • I deleted all files in the core/cache directory and repaired all tables with PhpMyAdmin

                    The problem is not solved. I - as before - can log in (using the pw given by the "forgot your login?" function on the manager login page), but still can not change any passwords or create a new user with a working password with the manager tools.

                    summerson
                      • 3749
                      • 24,544 Posts
                      I wonder if it could be a mod_security issue at your host.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting