-
☆ A M B ☆
- 66 Posts
Recently updated from 2.2.14pl to 2.3.1 and I do not have the Context menu in my manager.
Check the screenshot.
Any help is appreciated.
-
☆ A M B ☆
- 24,524 Posts
Check your user group's Access Policy to see if it has permission to view the Context menu. Look for view_context permission.
-
☆ A M B ☆
- 66 Posts
I am the Administrator and have all 172 checked...
-
☆ A M B ☆
- 66 Posts
Ok so when I check the link [[++site_url]]manager/?a=context I get an Access Denied.
Not sure how I can solve this while I am in the Admin Group, have Super User role with authority set to 0, using the Administrator policy with all 172 permissions checked...
Cleared cache multiple times, tried re-installing, checked the error log and have no errors... What else can I do?
-
☆ A M B ☆
- 24,524 Posts
Go look in the Menus menu item, and see if the Contexts menu item is there, and if it has anything odd in its configuration.
You might also check the modx_context table in PhpMyAdmin to see if it has a 'name' field. It should, but I've seen reports of upgrades where that column didn't get added. If it's missing, it might interfere with the context menu.
-
☆ A M B ☆
- 24,524 Posts
Hm. I recently had occasion to move a badly-behaving site, so I created a new installation, installed all of the same extras new, then imported the database from the old site. Gallery extra was not working. I noticed a lot of errors about a missing "year" field, and it turns out that the older version on the original site didn't have that field. I added it to the database, and suddenly everything was working again. So it might help to check the error log.
-
☆ A M B ☆
- 66 Posts
@ray:
I checked the modx_context table and this is a screenshot of its content. The name field is there.
@sottwell:
Checked the menu items and its there, when I update it it looks exactly the same...
I feel like I might try the approach Sottwell proposed, install new instance, get all extra's and install them and then copy over the DB export. Unless you guys have another idea I could pursue?
Is there anything helpful in the Error log (Manage -> Reports -> Error Log)?
-
☆ A M B ☆
- 24,524 Posts
I wasn't suggesting an approach, merely illustrating that a missing field in the database can break things.
I took that rather drastic approach because A. the site had been hacked and B. they already had a VPS sitting empty waiting to be used. I didn't trust any of the core files, other than the usual /assets/ image, .css, .js files and the like.