We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19872
    • 1,078 Posts
    Yikes. My MODx manager is all messed up. Tree items appear and disappear. No resources in the resources tree. Many of the other pages are simply blank. The blank page aspect is eerily similar to what happened last week when they tried to migrate a modx site over to cPanel for me.

    So looking for a little guidance, or even a vote of confidence. I'm on 2.2.6 and was actually planning to update. No.. really... I was! The site has been on the fritz all day and goDaddy acknowledges they are aware of some problems. So I don't know whether to proceed with an update or not. 15 minutes ago, support informed me that everything was A-OK with my server. Perhaps this is all related to goDaddy, and I might wind up trying to troubleshoot update issues that are not related to MODx or me at all.

    What do I do?

    Step One—I've backed up my database and all directories and files.

    Step Two—I've managed to turn off friendly URLs in system settings, and changed my .htaccess filename to ht.access.

    Step Three—Should I try deleting the contents of core/cache through the file manager, and then perhaps upload the setup folder from the 2.2.6 install zip and then run the setup in update mode.

    I suspect this is some kind of path issue. They claim there has been no migration, but the backend looks different, and there's messages about how they're improving the system for me. This particular install is on an alias domain as part of their Ultimate Hosting. MODx always worked pretty well—no problems to speak of.

    This question has been answered by sottwell. See the first response.

    • discuss.answer
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Definitely delete the core/cache directories. Running the save version's setup in upgrade mode can't hurt. Also make sure to clear your browser cache and cookies. You also might try getting into the database, in the system_settings table find "compress_css" and "compress_js" and turn those off (change from 1 to 0).
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 19872
        • 1,078 Posts
        Hi Susan:

        Thanks for responding. The site itself loads fine, but I suspect something funny is going on with goDaddy. I haven't even been in the manager for at least a couple of weeks.

        I'm going to wait until tomorrow just to rule out that goDaddy doesn't have something going on there that they're not being forthcoming about.

        I appreciate your responding, and will start with deleting the core/cache.

        Marc

          • 19872
          • 1,078 Posts
          Hi Susan:
          Deleting the core/cache fixed the issue.
            • 19872
            • 1,078 Posts
            Did the update to 2.3. Website loaded fast and fine on the front end. Initially the manager had some issues (templates not visible, etc. and then finally got a blank screen after clicking around to much.) Then the site could not be loaded from the front end. I deleted the core/cache, now able to log in to the manager and get to the error log:

            [2014-07-21 21:26:08] (ERROR @ /index.php) [OnWebPageInit]1
            [2014-07-21 21:26:09] (ERROR @ /index.php) [OnWebPagePrerender]1
            [2014-07-21 21:26:17] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href='function.get-headers'>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
            [2014-07-21 21:26:17] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href='function.get-headers'>function.get-headers</a>]: This function may only be used against URLs
            [2014-07-21 21:26:19] (ERROR @ /connectors/lang.js.php) Error caching action map mgr/actions
            [2014-07-21 21:26:19] (ERROR @ /connectors/lang.js.php) Error caching lexicon topic lexicon/en/core/resource

            The first two I presume are related to Extras that need return;
            The remaining errors, I don't understand.
              • 19872
              • 1,078 Posts
              some of the manager functions seem OK. In the Elements tree I can see my list of templates, but TVs Chunks Snippets Plugins all are empty. Clicking on the button toggles it's panel open just a little bit, rather than opening and showing the list of contents.

              Then with the File Tree. Images opens and shows the list of images. However, inside my images directory I have a couple of sub directories that have a triangle to the left. When I click to toggle those directories open, there is nothing listed.

              Seems like everything is just a tad bit wack-a-doodle.

              At this point, I'm afraid to click around much more. Essentially, the site is working on the front end. If I click around too much and freeze up the manager, then the front end seem to stop working as well.

              Suggestions for a remedy welcome.
                • 3749
                • 24,544 Posts
                First, make sure compress_js and compress_css are still off after the upgrade.

                You're right about the first two error messages. There is a fix for that in 2.3.1.

                It looks like your server has allow_url_fopen turned off and something is using fopen() on a URL. It's probably an extra (I don't think MODX itself would do that). I don't know what it might be (it's not one of mine wink ). The times of the errors might be a clue.

                The "error caching" errors can be due to an overloaded server. It's possible that there's a permission issue with your cache directory, but then I'd expect to see a lot more of those than you're getting.


                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 19872
                  • 1,078 Posts
                  Hi Bob: Thanks for jumping in here. I think there's more errors occurring in the log. I'll log back in to see, and also check the compress situation.

                  I am looking at the goDaddy error log, but don't think these apply to my 2.3 install, as that was done and completed around 11:00 - 11:30 pm Central Standard Time

                  11:55 if that's almost noon, would be earlier today, before any update of MODx.
                  21:08 would be approximately 9 PM, which also was before I started doing my update, so maybe just server errors in general, maybe with modx 2.2.6 but then maybe not?

                  Below are some errors I grabbed from the goDaddy error log, happening I think just after i updated and was first navigation around the manager.

                  [Mon Jul 21 11:55:52 2014] [#######] [fcgid:warn] (104)Connection reset by peer: [client ###.###.###.##:#####] mod_fcgid: error reading data from FastCGI server, referer http://www.beachhouseatpleasantbeach.com/manager/
                  [Mon Jul 21 11:55:52 2014] [#######] [core:error] [client 207.191.219.83:45585] End of script output before headers: index.php, referer http://www.aliasDomainName.com/manager/
                  [Mon Jul 21 21:08:24 2014] [#######] [negotiation:error] [client 66.249.84.123:53929] AH00687: Negotiation: discovered file(s) matching request: /var/chroot/home/content/##/#######/html/aliasDomainAccount/index.php (None could be negotiated)., referer http://www.primaryDomainName.com/
                    • 19872
                    • 1,078 Posts
                    More identical errors in the MODx error log. Compress CSS and Compress JS were set to 'No'

                    Here is the most frequent error:
                    [2014-07-21 21:43:34] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href='function.get-headers'>function.get-headers</a>]: This function may only be used against URLs

                    My Extras are Up to Date:
                    getResources (which I'm not actually employing on this site) It does not have return; at the end. Just return $output;
                    TinyMCE (it has return; at the end of the code)
                    Wayfinder No return; at the end of this one either
                    GoogleSiteMap

                    There is a plug-in called Core Services. No return; at the end of its code.

                      • 19872
                      • 1,078 Posts
                      Actually, now clicking on Check for Update on the Extras does bring up the model. Each Extra is up-to-date.