I am continually revisited by a reoccurring issue where my site stops working. The manager works, but no content loads on the page when navigated to.
Clearing my site cache always seems to resolve the issue.
The site is hosted on a really old server and I have the option of moving it to their new cPanel environment. I also need to upgrade from MODx 2.2.8 to 2.2.14. Apparently the move will require me to actually download the site files and then upload them to the new cPanel environment. My own experience tells me that merely downloading from one server and uploading to another server will be rife with all kinds of permission issues. As well, I would also need to import my database.
I've seen reference to something called Vapor. Would that be perhaps a better method for porting the site?
As well, if I create the new database in the cPanel environment, should I be careful to give it the exact same name and login info?
Also—Should I first upgrade the current site to 2.2.14 before porting it to the new cPanel environment?
Any tips here greatly appreciated. Note: I am stuck with this hosting company for this particular site, so hoping to be able to make it work.
Just some additional notes here. goDaddy support mentioned that maybe the old server is running a version of PHP that is old or not compatible with MODx
Current MODx install = 2.2.8
Current PHP on server = PHP Version 5.3.24
Current mySQL = 5.0.96-log
My bandwidth and disk space usage is a tiny fraction of what's allowed. I'm currently using 72+/- MB of 1.5 GB of space. The site only contains a handful of pages. Very simple.
Yikes... what is going on?
Do you have access to the error.log?
Could you post the content of the log once the site goes blank? I is almost impossible to guess what the problem might be, because there is a 100 things that could go wrong.
However, I have experienced this on sites where the cache that was saved was corrupted, so when Modx tired to load the cache files the array was incomplete causing a 500 parse error in the error.log.
I have received some type of parse error before, and think I got that resolved by tying up some loose ends with TVs and content that was not needed in the site. In my mind I think MODx was continually looking for something that was not available, and then continuing to look over and over and over again until it exhausted the bandwidth. Of course—my interpretation could be completely inaccurate.
At this point, the error log is filled with the same error related to Zend Manager. The only difference among them is the client IP. But the site is loading, so as this point, I can only assess that the Zend error is unrelated.
This is a sample error found in the goDaddy error log. They could not explain, but said it should no affect whether the site loads or not. The error messages are all the same in this instance, except that each has a unique client IP number.
[Thu Jul 10 05:36:59 2014] [error] [client 97.74.104.6] Cannot load Zend Extension Manager - it was built with configuration 1.2.0, whereas running engine is API220090626,NTS
[Thu Jul 10 05:36:59 2014] [error] [client 97.74.104.6] Failed loading /usr/local/zo/4_3/ZendOptimizer.so: /usr/local/zo/4_3/ZendOptimizer.so: undefined symbol: empty_string
This is really the only MODx site I have been having this type of issue with, and I have several other on goDaddy servers, but on newer plans / servers.
I will monitor closely over the next couple of days while I figure out how to efficiently copy the current site so I can post it to the newer server plan once goDaddy changes the account for me. I've never moved an existing MODx site before, so this should be interesting.
[ed. note: mmcgee last edited this post 12 years, 2 months ago.]
Some earlier 2.x versions of MODX suffered from cache corruption (and serious security issues). That said, I've seen a number of reports of problems with MODX at goDaddy.
http://bobsguides.com/modx-friendly-hosts.html
Hi Bob:
Thanks for responding. This is the same site that I made the other post you responded to regarding upgrading / merging.
So... I'll upgrade to 2.2.14 first. And then attempt to move the site to the new cPanel hosting.
It's the merging of directories that had me stuck at the moment. Thought I would do with SSH, but with this goDaddy account, enabling SSH gave a warning that in order to enable SSH, the account would be automatically upgraded to cPanel, which I am not ready for yet because I need to update the site. The automatic move message also indicated that I would have to repost all site files to the server. So.. kind of stuck at the moment while I plan my strategy.
I'm not sure this answers your question, but if you upload a .zip file and use cPanel's unzip (I think it's called extract), the new files will overwrite the existing ones and won't touch any existing files or directories that are not in the .zip file.
Maybe I need to zip each individual directory of the new MODx install and upload. That way my mac isn't creating a parent directory, which is what happens when I select multiple items and select compress.
I'm not currently in a cPanel environment however. Not sure whether that will make any difference or not. I do know that when I'm on the server using the File Manager and I attempt to "move" a directoy out to the root, I get a prompt that it will overwrite that directory, which is not what I want to happen.
I'll create some test folders and perform the maneuver to see if what happens.
Well. It's a no go. The file manager will overwrite a directory with the same name. There's actually a warning, and the only way to extract and archive that has the same name as an existing archive is to overwrite the archive.
I've also tried opening two different file manager windows at the same time, and that does not work either.
I may simply have to contact support and see if they are able to merge directories on their end.
This is the instruction at MODx Docs
Do Not Overwrite Directories!
Make sure your FTP program merges directories and does not overwrite them!
The suggested FTP applications CODA & TRANSIT will merge directories from local to remote & vice versa, but not within the same remote.
When attempting to use FETCH by opening two connections, and then dragging one folder from one window out to the root in the other window, I get an error: Rename/move failure: File exists. So even Fetch or using two windows side by side doesn't work.