I needed to add a script and related files to my site outside of MODx. I uploaded the directory to my server and visited the appropriate URL only to get a error 404. Attempted different directory and even added the directory to the .htaccess file next to manager and assets. No dice. Running 1.0.12 on Centos VPS on AWS EC2.
Any advice or solutions? Under the gun to get this solved as I thought it would be a quick one.
Thanks in advance.
Okay, noticing that I am due to upgrade I uploaded 1.0.13 and went to install. Got a error 404. Renamed .htaccess and tried to visit the installer and got a default server 404 page. So I am thinking maybe it is an issue with my .htaccess file.
What to do?
Tried the default .htaccess file and no dice there either.
Any help here? This is fairly significant of an issue...
-
☆ A M B ☆
- 1,780 Posts
This sounds like something your host should be helping you with. Files and .htaccess writes outside of MODX aren't something those around here specialize in normally.
Well the files are within the same directory as MODx just a level down. Why would MODx take over for files that actually exist?
The strange thing is that I first put the files within the assets directory, then added them in a different directory and same result.
-
☆ A M B ☆
- 1,031 Posts
Do the files you try to access on your webserver have sufficient rights to be read (folders have to be executable) by Apache?
There should not be anything disturbing direct folder/file access beside the assets/cache folder (inside there is a deny from all setting created during installation).