We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19872
    • 1,078 Posts
    I've notice that the following error occurs each time I toggle to view a resource that has MIGx item (a slider in my case) as part of the template for that page. The errors always come in groups of 3. Not sure if that means MODx is making 3 attempts and then gives up. It does not occur when toggling to view a resource that doesn't have MIGx.

    Would someone please be able to shed some light on what this error means and what I might do to resolve it?


    [2014-03-19 12:41:37] (ERROR @ /manager/index.php) Error 42S02 executing statement:
    Array
    (
    [0] => 42S02
    [1] => 1146
    [2] => Table 'mynamemodx.modx_migx_configs' doesn't exist
    )

    [2014-03-19 12:41:37] (ERROR @ /manager/index.php) Error 42S02 executing statement:
    Array
    (
    [0] => 42S02
    [1] => 1146
    [2] => Table 'mynamemodx.modx_migx_configs' doesn't exist
    )

    [2014-03-19 12:41:37] (ERROR @ /manager/index.php) Error 42S02 executing statement:
    Array
    (
    [0] => 42S02
    [1] => 1146
    [2] => Table ‘mynamemodx.modx_migx_configs' doesn't exist
    )



      • 4172
      • 5,888 Posts
      As soon, as you've installed MIGX completely

      http://rtfm.modx.com/extras/revo/migx#MIGX-InstallationInstructions


      16. Click the Setup / Upgrade tab
      17. WARNING: Before this next step, you probably want to ensure that you've created a snapshot of your database.
      18. Click the Setup button

      this error should go away.
        -------------------------------

        you can buy me a beer, if you like MIGX

        http://webcmsolutions.de/migx.html

        Thanks!
        • 19872
        • 1,078 Posts
        Thanks Bruno. I'll review the instructions. Snapshot of the database? I can only access with SSH, but I think I have a command line for downloading a copy.
          • 19872
          • 1,078 Posts
          Pardon my novice question here. mysqldump and "snapshot" is essentially the same thing, correct? [ed. note: mmcgee last edited this post 12 years, 6 months ago.]
            • 4172
            • 5,888 Posts
            There isn't a resolver created for that package, which does create the tables.
            You need to click the setup-button there, which does nothing, than creating the config-table.
              -------------------------------

              you can buy me a beer, if you like MIGX

              http://webcmsolutions.de/migx.html

              Thanks!
              • 19872
              • 1,078 Posts
              OK. Thanks for the help.
                • 19872
                • 1,078 Posts
                Hi Bruno17

                I did a mysqldump and now am in the Actions panel and see the migx category. There is already an index in that category — index(78)
                As well, in the Top Menu, under Components, there is already MIGX (index/index.php)

                In kind of reviewing the steps at the link you provided, it looks like these items are already in place.

                  • 19872
                  • 1,078 Posts
                  As well, MIGx is appearing in the components menu. Honestly, that is a menu item I have never clicked on.

                    • 19872
                    • 1,078 Posts
                    So am I to assume that steps 1 - 12 were already completed from when I installed the package through the package manager?

                    Do I then only need to do the update steps 14 -18?

                    Personally, I rather be at 19... Done!
                      • 4172
                      • 5,888 Posts
                      yes, some of them could be removed from instructions, as they are done automatically with the package-installation.

                      you really just need
                      16 + 18
                        -------------------------------

                        you can buy me a beer, if you like MIGX

                        http://webcmsolutions.de/migx.html

                        Thanks!