We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 45739
    • 64 Posts
    For almost any action I try to do in the MODX Manager, I get this error:

    Unexpected token <:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    I will also attach a screenshot.

    I thought it may have something to do with the .htaccess file, so I renamed it but am still getting the same error.

    I have tried to upgrade from MODX 2.2.9 to 2.2.10 and am still getting the same exact error

    If anyone could help me with this it would greatly be appreciated, as I can't do ANYTHING in the MODX manager.

    Thanks!
      • 3749
      • 24,544 Posts
      Do you remember what you did on the site before it started -- e.g., extras installed or uninstalled?

      Do you have any plugins that act in the Manager? That error is often caused by an E_NOTICE error being thrown by a plugin.

      Another possibility is a syntax error in a lexicon file. One of the gallery extras can cause this when uninstalled.

      You may find something useful in the MODX error log (core/cache/log/error.log) or in the Server error log.

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 45739
        • 64 Posts
        Quote from: BobRay at Nov 16, 2013, 03:08 PM
        Do you remember what you did on the site before it started -- e.g., extras installed or uninstalled?

        Do you have any plugins that act in the Manager? That error is often caused by an E_NOTICE error being thrown by a plugin.

        Another possibility is a syntax error in a lexicon file. One of the gallery extras can cause this when uninstalled.

        You may find something useful in the MODX error log (core/cache/log/error.log) or in the Server error log.


        I do not believe I did anything specific that caused it. I do know that I have multiple contexts, 9 contexts to be exact. But they are all setup and configured correctly, Two contexts however, are forums, but I don't see how that would affect it either.

        Here is the error log:

        https://gist.github.com/anonymous/3c40fcfba427025c3051
          • 45739
          • 64 Posts
          Also, here are my add ons
            • 3749
            • 24,544 Posts
            It could be a problem with the MySQL connection at the host, though if you were able to run setup when upgrading, that's probably not it.

            If setup wouldn't run, I would ask your host about any problems with the MySQL server.

            If setup did run OK, I would try disabling those plugins in the modx_plugins table in PhpMyAdmin.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 45739
              • 64 Posts
              Quote from: BobRay at Nov 16, 2013, 03:41 PM
              It could be a problem with the MySQL connection at the host, though if you were able to run setup when upgrading, that's probably not it.

              If setup wouldn't run, I would ask your host about any problems with the MySQL server.

              If setup did run OK, I would try disabling those plugins in the modx_plugins table in PhpMyAdmin.

              Should I delete the plugins i see under dbase > modx site plugins?
                • 45739
                • 64 Posts
                Quote from: BobRay at Nov 16, 2013, 03:41 PM
                It could be a problem with the MySQL connection at the host, though if you were able to run setup when upgrading, that's probably not it.

                If setup wouldn't run, I would ask your host about any problems with the MySQL server.

                If setup did run OK, I would try disabling those plugins in the modx_plugins table in PhpMyAdmin.

                I have uninstalled EVERY MODX plugin I had installed (through the package management). I am still getting that same error.

                Any other ideas?
                  • 3749
                  • 24,544 Posts
                  Did setup run OK (try it again)?
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 45739
                    • 64 Posts
                    Quote from: BobRay at Nov 16, 2013, 10:14 PM
                    Did setup run OK (try it again)?

                    Yes there are no problems with the upgrade
                      • 3749
                      • 24,544 Posts
                      I imagine you've tried these but in case you haven't:

                      - Turn the compress_js and compress_css System Settings off in the modx_system_settings table in the db with PhpMyAdmin.

                      - Delete all files in the core/cache directory

                      - Clear your browser cache and cookies.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting