Do you know which request produces the error? Please check the various server responses with the developer console to narrow down the problem.
-
☆ A M B ☆
- 24,524 Posts
You cannot have any rewrite rules before the rewrite engine is turned on.
There is a ht.access file in the /manager/ directory that will simply turn the rewrite engine off for the Manager if you rename it.
-
☆ A M B ☆
- 24,524 Posts
Is your own server installed in a subdirectory with a parent directory where the rewrite engine already turned on?
-
☆ A M B ☆
- 24,524 Posts
Well, I've had different servers behave differently as far as .htaccess processing goes. It probably depends on the version of the server, as well as its own httpd.conf configurations.
discuss.answer
The unexpected token message is often caused by a plugin or CMP throwing an E_NOTICE error. It doesn't usually cause a 500 error, but it might on some servers.
See this:
http://bobsguides.com/blog.html/2013/05/22/debugging-cmps-a-horror-story/
It's also possible that you just have a corrupted file in your MODX install. That's fairly common if you transfer the MODX files individually with FTP.