-
☆ A M B ☆
- 24,524 Posts
Try going into the database with phpMyAdmin and in the system_settings table set compress_js and compress_css to 0.
Did you try to rename the ht.access files that come with the installation to .htaccess?
-
☆ A M B ☆
- 24,524 Posts
Another thought... how did you install Revo? Did you upload all the extracted files? It's better to upload the zip file then extract on the server and move the top-level files and directories into place once extracted.
I have changed the suggested files and still no luck, The files were unzipped when I uploaded them, would this be part of the issue. Should I clean install again using the unzipping on the server method...
-
☆ A M B ☆
- 24,524 Posts
I would try that; it's quite common for a few files to get corrupted when uploading as many files as Revo has.
That error is sometimes caused by having a third-party cache system like Xcache or memcache implemented on the server.
-
☆ A M B ☆
- 3,141 Posts
An internal server error has to leave traces, though where depends on the server configuration. Look inside the manager directory as well as connectors/ to see if there is an error_log file, or check your server control panel for an error log option. Sometimes it may also go to a specific location on the server, such as ~/error_log or ~/logs/error_log. The contents of that should give a better idea of why the request is failing so badly. If you have SSH access, you could try to find files by the name of error_log - that seems to be pretty consistent across configurations.
Hi
I have now tried to reinstall several times andceach time I still get the same error
In Chrome it was alright but not getting sytax error unexpected tocken >
I get the same in safari..but in firefox it just says internal error...
Am I missing something...
will try and add server log later...
thanks
Hi in my error logs these are the items that are getting 500 errors.
POST /connectors/element/template.php - 500 617
GET /manager/min/index.php f=/manager/assets/modext/widgets/security/modx.grid.user.recent.resource.js,/manager/assets/modext/widgets/modx.panel.welcome.js,/manager/assets/modext/sections/welcome.js 500 617
Can someone point me in the right direction for this...I am starting to think that I may need a different CMS, however I really like MODX, so really want to fix this error.
I have also tried to install MODX from the hosting CGI Script but I still get the same error...
Thanks
Louise
-
☆ A M B ☆
- 3,141 Posts
Hi Louise,
You can try to disable the compress_js setting. If you can't get to the system settings currently, open the cache file in core/cache/system_settings/ and change the value in there from 1 to 0; that may fix the manager issue for you. If it does, make sure to go to System > System Settings and change the value there as well, so it is changed in the database and not just the cache.
You could inspect the return values from those requests you posted as well, there might be an error message in there. Otherwise it should be in the server error log, but where that is located varies heavily per server, so asking the host is easiest.