We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8168
    • 1,118 Posts
    Hi guys,

    I am running MODx Revolution 2.0.4-pl2 with a blog which I created based on the tutorial here > http://rtfm.modx.com/display/revolution20/Creating+a+Blog+in+MODx+Revolution

    The blog works fine, but after a few days, when one visits the blog pages (any of them, e.g. index or blog article pages), all one sees is a blank white page.

    If I log in to the manager and clear the site cache, the pages appear once more...

    What is going on here?

    Any ideas for a fix anyone?

    This question has been answered by dubbs. See the first response.

      • 8168
      • 1,118 Posts
      I think I just solved this by making the ’Archive’ resource be uncacheable... I did this and bang its back working even without clearing the site cache... I will keep an eye on this and update if this did in fact not fix it...

      I read this post to get the idea https://forums.modx.com/index.php?topic=56420.0
        • 8168
        • 1,118 Posts
        I can confirm, the fix mentioned on previous post DID NOT WORK... same error once more... Any ideas anyone? Clearing cache seems to fix problem.. but what is causing it so I can prevent it rather than keep having to clear the site cache daily!
          • 3749
          • 24,544 Posts
          It sounds like something is corrupting your cache. I would upgrade to 2.2.8 (after backing up the site) -- some 2.0.x versions had trouble with cache corruption.

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 8168
            • 1,118 Posts
            Quote from: BobRay at Jul 04, 2013, 04:18 PM
            It sounds like something is corrupting your cache. I would upgrade to 2.2.8 (after backing up the site) -- some 2.0.x versions had trouble with cache corruption.


            Thanks Bob - I will install a new version on another server and migrate content over and see if it fixes it... good plan - any reason why not to jump up to 2.8?
              • 9207 ☆ A M B ☆
              • 2,475 Posts
              Definitely check your PHP and MODX logs for errors. I agree with Bob -- it sounds like your cache is getting poisoned and the site barfs. This could be due to a bad Snippet or Plugin not handling an unexpected condition gracefully. Sometimes adjusting your error settings can help a lot because they would keep the errors in the logs and out of the cache.
                • 3749
                • 24,544 Posts
                I'd try clearing the site cache and the error and manager logs (Reports -> Error Log, System -> Actions), then back up the site and disable all plugins (especially the anything that deals with users) and going straight to 2.2.8. Run Setup and clear your browser cache and cookies before logging in (and delete all files in the core/cache directory for good measure).

                If it doesn't work, you can try upgrading to the intermediate versions, but you shouldn't have to.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 44432
                  • 7 Posts
                  Is your server running APC or XCache?
                    • 8168
                    • 1,118 Posts
                    I deleted the large (5mb) error_log files in the "cache" folder the other day and since doing that I have not encountered the issue of white pages... odd... but must be related I'd say....

                    dfunk006 - I am not sure to be honest...
                      • 44432
                      • 7 Posts
                      You can create a php file (phpinfo.php) with the following code:

                      <?php 
                      	phpinfo();
                      ?>


                      Upload the file on your server (where your index.php file is) and call it as follows: http://yourdomainname.com/phpinfo.php

                      There you can search for 'APC' and 'XCache' to see if it is installed.