On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I am trying to update 1.0.4 to 1.0.9 and seem to be having this same problem. "Warning: array_combine(): Both parameters should have at least 1 element in c:\wamp\ etc...etc...\protect.inc.php on line 54" I have php v5.3.4 I just tried the fix below but still get the error on log in attempts. Only downloaded 1.0.9 today so no fix has been done to the download files. I DO NOT KNOW PHP! Just want it to work...Please help

    Quote from: jasonabird at Mar 21, 2013, 03:00 PM
    Just used this one and fixed issue on 5.2.13.

    Is this going to get integrated in the 1.0.9 and re-released hopefully? Seems like with a bug that stops it from working right < 5.4 there should be a new push of the file.
    Quote from: dmi3y at Mar 19, 2013, 09:27 PM
    in file manager/includes/protect.inc.php line 54
    -    $target = array_combine($keys, $values);
    +    if(!empty($keys)){ //for compability php < 5.4.0
    +      $target = array_combine($keys, $values);
    +    }
    • Thanks for the fix, worked ok for me.