We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 1169
    • 312 Posts
    I am busy trying to get restarted with MODX
    REVOLUTION 2.2.4
    Server Details
    PHP 5.2.17
    mysql 5.0.95
    Mem 32mb

    all install tests pass
    No warning errors
    Have reinstalled twice same problem

    No problem with Revo 2.1.1 (a while ago)

    In Manager on loading any menu page or Home page

    I get following error:-

    Unexpected token <:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    From CPANEL Server Error log:-

    [Mon Sep 10 09:48:53 2012] [error] [client 41.151.114.193] File does not exist: /SOMEDIR/newrevo/404.shtml
    [Mon Sep 10 09:48:53 2012] [error] [client 41.151.114.193] File does not exist: /SOMEDIR/newrevo/favicon.ico
    [Mon Sep 10 09:48:45 2012] [error] [client 41.151.114.193] File does not exist: /SOMEDIR/newrevo/500.shtml, referer: http://new.allanb.za.net/manager/?a=67
    [Mon Sep 10 09:48:45 2012] [error] [client 41.151.114.193] File does not exist: /home/ctsoeorg/public_html/newrevo/500.shtml, referer: http://new.allanb.za.net/manager/?a=67
    [Mon Sep 10 09:48:45 2012] [error] [client 41.151.114.193] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /SOMEDIR/newrevo/connectors/system/activeresource.php, referer: http://new.allanb.za.net/manager/?a=67
    [Mon Sep 10 09:48:45 2012] [error] [client 41.151.114.193] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /SOMEDIR/newrevo/connectors/system/databasetables.php, referer: http://new.allanb.za.net/manager/?a=67

    Any help solving this problem would be appreciated [ed. note: allanb last edited this post 14 years ago.]
      DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
      • 3749
      • 24,544 Posts
      I'm not sure if this is the real problem, but look in the web root of the server for those files ending in .shtml and copy them to the MODX web root. That should knock out some of those errors.

      The other errors suggest that you might have one or more corrupted or missing MODX files. This is common if you used FTP to transfer the files individually (see this for another method: http://bobsguides.com/modx-upgrade-faq.html -- the page is about upgrading, but the file transfer method works for new installations).




      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 1169
        • 312 Posts
        Thanks @BobRay

        I have fixed the file does not exist as you suggested

        I did upload via zip file

        I have used same file on localhost and free webhost OK on both only difference PHP 5.2.17(problem)
        PHP 5.3.x (working)

        Mem on not working 32mb
        Mem on working 48mb+

        Tried php.ini with 128mb mem in webroot, & manager if I run a info.php from either dir phpinfo reports increased mem
        but from phpinfo from within manager still only 32mb

        Host also at a loss.
        [ed. note: allanb last edited this post 14 years ago.]
          DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
          • 3749
          • 24,544 Posts
          It definitely looks like a memory issue, but I don't know what would cause that.


          ------------------------------------------------------------------------------------------
          PLEASE, PLEASE specify the version of MODX you are using.
          MODX info for everyone: http://bobsguides.com/modx.html
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 1343 ☆ A M B ☆
            • 2,213 Posts
            I would highly recommend upgrading to php 5.3.x as there is no longer support/bug fixes for php 5.2.x, granted this isn't likely the cause of the problem.

            I'm with Bob, it sounds like a memory issue, and your host should be able to correct the problem, otherwise I would recommend getting a new host. Increasing the php memory limit is very basic work for any hosting provider.

            That being there could be other php settings that are causing and/or contributing to the problem. Could you share the php info on the new server?
              Patrick | Server Wrangler
              About Me: Website | Tweets |  MODX Hosting
              • 1169
              • 312 Posts
              Thanks guys
              I agree with both of you.

              The server ran with 2.1.0
              Have there been any increased server requirements since then?

              Should I attach phpinfo as a file

              Regards
              Allan
                DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
                • 3749
                • 24,544 Posts
                I don't know the specifics, but I think most MODX versions use more memory than the previous version. 32M is a little small for something the size of Revolution. Your host may have it capped at that (which is why you're setting doesn't change it).



                ------------------------------------------------------------------------------------------
                PLEASE, PLEASE specify the version of MODX you are using.
                MODX info for everyone: http://bobsguides.com/modx.html
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 1343 ☆ A M B ☆
                  • 2,213 Posts
                  There shouldn't be a drastic change in memory usage between 2.1.x and 2.2.x, if anything it should have improved some.
                    Patrick | Server Wrangler
                    About Me: Website | Tweets |  MODX Hosting
                    • 1169
                    • 312 Posts
                    I create a file phpinfo.php with the following code
                    memory_limit = 128M
                    max_execution_time = 45
                    upload_max_filesize = 10M
                    post_max_size = 20M
                    extension="pdo.so"
                    extension="pdo_mysql.so"


                    in the manager dir of site

                    I navigate to site site/manager/phpinfo.php

                    and get a phpinfo file with 128mb memory

                    I delete all cache files on site and log into manager
                    Select <Reports then <System Info and get phpinfo with 32mb memory

                    Do you have any ideas?
                    [ed. note: allanb last edited this post 14 years ago.]
                      DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
                      • 1169
                      • 312 Posts
                      In desperation I re Downloaded 2.2.4 zip to different machine

                      Uploaded zip file to host

                      Using CPanel unziped to new dir

                      Created new subDomain and redirected to new dir

                      Copied php.ini file and info.php to root, manager and setup dir's

                      Navigated to info.php in each dir and got 128mb mem in each.

                      Created new database

                      Ran setup. Setup reported 128 mb men after connecting to DB

                      copied error files to root and flavicon.ico

                      Now only cannot allocate memory in error log

                      Still shows 32mb Mem from >Reports>System Info <view> PHPinfo

                      Seems now definite server fault
                      Not corrupt file uploads

                      PHP 5.2.17

                      At a loss

                      Thanks for help so far.
                      Allan
                        DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31