Hi All,
I upgraded to 2.2.4 from 2.2.1 last night and since have been unable to save any templates. When I click save I get presented with the error template_err_nfs. See attached screenshot. Any ideas what may be causing this?
Thanks,
Daniel
In addition to this i can no longer save chunks i get the error Chunk not found with id: [[+landing:default=[[*id]]]]
I have now done a full cPanel restore from a backup created before the upgrade, and the problem seems to still be occuring, really stuck on ideas now! I thought it may have been to do with installing Articles however i've completely uninstalled that.
It's possible that your host has implemented or changed mod_security.
http://wiki.modxcms.com/index.php/What_is_mod_security_and_how_does_it_affect_me. That's the usual culprit when you can save some things but not others.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
Hi Bob,
Thank you for your reply, when I do the first step in that article I get an Internal Server Error (500).
Many hosts don't alow PHP directives in .htaccess. You'll have to use another method (e.g., php.ini) or consult with the host.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
I dont think mod_security is my problem anymore I have tried most of the points in that article, and have also wrote a .conf file attached to httpd.conf for the account and disabled mod_security and i am still seeing the errors. At the bottom of the article too it says to try saving line by line, well I cant even save the Template with no content.
That could be a date/timezone issue. The date/timezone for MODX, PHP, and MySQL have to match in 2.2.4. Check the date_timezone System Setting and see this:
http://codingpad.maryspad.com/2012/03/19/setting-the-time-zone-for-php-5-3-x/#more-1972
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
Hi Bob
Thankyou for your help, I checked all the time zones and Modx's wasn't set so I proceeded to Set it to Europe/London and it solved the problem.
I'm glad you got it sorted. Thanks for reporting back.
It's still curious that you got that error message, which is a language key and should have been replaced by a more sensible language string unless the date/timezone issue also affected the loading of the Lexicon strings.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html