We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38833
    • 1 Posts
    Hi!

    After a fresh install of Revo I try to access manager. Menu on top looks fine, but there is nothing in the content area. In JS console i get
    http://zawrat.edu.pl/manager/min/index.php?f=/manager/assets/modext/core/modx.localization.js,/manager/assets/modext/util/utilities.js,/manager/assets/modext/core/modx.component.js,/manager/assets/modext/widgets/core/modx.panel.js,/manager/assets/modext/widgets/core/modx.tabs.js,/manager/assets/modext/widgets/core/modx.window.js,/manager/assets/modext/widgets/core/modx.tree.js,/manager/assets/modext/widgets/core/modx.combo.js,/manager/assets/modext/widgets/core/modx.grid.js,/manager/assets/modext/widgets/core/modx.console.js,/manager/assets/modext/widgets/core/modx.portal.jsFailed to load resource: the server responded with a status of 502 (Bad Gateway)
    2ext-base.js:7Uncaught TypeError: Cannot read property 'prototype' of undefined
    ext-all.js:7Uncaught TypeError: undefined is not a function

    I've tried few times with the same effect.
    There were no errors during installation.
    Does anyone know where the problem is?
      • 38847
      • 5 Posts
      Have the same problem here. After installation can do nothing except clicking manager menu items. Only Dashboard show some text and "Package management" warns that I should get curl. In addition dozen of js errors on each page.
      Tried on severial browsers and two computers (with different OS).
        • 10208 ☆ A M B ☆
        • 1,780 Posts
        Yes, this issue can be frustrating but here's some things to try.

        Try setting compress_js and compress_css to off (0) in the manager settings. If you can't access the settings from the manager, use phpMyAdmin and change the values in the manager_settings table manually.

        Clear the cache manually by deleting all the files in the core -> cache directory.

        Make sure register_globals is OFF in php.ini. Check to make sure that it's OFF in MODX. In the menu, select Reports -> System Info. Then click the link to php.ini and check the register_globals setting. It can be off in all your php.ini files and still show as ON in MODX if your server's php.ini register_globals is set to ON in the root, and .htacces is not set to be recursive. Your host can help you more with this, I still don't understand it very well but I do know it's an issue with some hosts.

          Frogabog- MODX Websites in Portland Oregon
          "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
          Having server issues? These guys have MODX Hosting perfected - SkyToaster
          • 38630
          • 21 Posts
          I have the exact same problem with a new install. I am running Apache on windows 7. Everything seems fine but I can't access any of the menu items, I just get a blank screen. I will try the suggestions above and report back.
            • 38847
            • 5 Posts
            where can I find manager_settings table? I cant see in table list in phpMyAdmin and cant find text like "compress_js" and "compress_css" in all other tables.
              • 38630
              • 21 Posts
              It will be something like mod_manager_settings
                • 1778
                • 659 Posts
                hello
                this is not 'manager_settings' but 'modx_system_settings' (assuming your tables are prefixed with 'modx_'
                Cheers
                  • 38847
                  • 5 Posts
                  Oh god, it worked. Thank you guys.
                  Changed compress_css and compress_js to 0, cleared cache dir and at last it works. [ed. note: calamander last edited this post 14 years, 6 months ago.]
                    • 40315
                    • 1 Posts
                    Had a similar problem after moving my site to a new host - and I am happy to report that it was fixed as outlined above.
                      • 5129
                      • 1 Posts
                      Mods, Please add this issue to Troubleshooting Installation section in the Documentation...

                      I think this problem is quite common in free web hosting, and I have to get frustated for 3 days before finding these solutions...

                      Thank you very much...