I just finished swiping my server after a huge permissions bug and I've been reinstalling all my MODX sites (most were drag, drop and alter config). With most I've deployed them as before at their current version however I'm having big issues with one.
The site was an Advanced install with the core being shared between two setups originally, although one site was abandoned and the setup wasn't changed for the site in deployment.
I lost the core directory when I moved servers (as it was outside of the Public HTML folder and I missed it on the backup), I don't have any other versions available. I tried to reinstall with 2.2 and starting with a fresh core that I could then add the same packages too, I rewrote the config file and the new core folder was decompressed.
The install completed without error (other than fixing permissions) and I can log into the manager, however, the directory/resource tree won't show up, and the usual 'Clear Cache', 'Flush Sessions' etc. doesn't work. Creating a resource results in a blank page and so does navigating to the sites root. It's effectively a version of the manager without any JS working, and there's nothing in the server error logs about the blank page for the sites home.
The core obviously has an empty cache (other than manager files), I can't flush any sessions from the manager. Can anyone help me figure this out please?
[ed. note: RLB last edited this post 14 years, 7 months ago.]
Hi Ralph, I've just got my site working:)
Apart from admin I was also facing an issue where emails wouldn't send from the client side (my client side was working), despite the fact that I've tried hundreds of combinations.
Anyway, I was just on the phone to the hosting support guy, got him to turn on php error reporting. I'd just upgraded all my files again (in desperation) and the error reporting highlighted that I overlooked something I'm aware of. The manager->controllers->default->welcome.class.php causes a problem. If you rename it you should be able to login...UNLESS...
That still didn't do it for me. It turns out upping the memory did the trick! All of a sudden my mails are sending and I have full access to admin.
Maybe copying all the files over helped...I can't be sure, but I have shared all I know;)
I really hope you get on top of your issues!
Thanks for the feedback Supanick. Incidentally I've also just got my site working, or at the least the frontend. I enabled logging too (dedicated server so luckily complete control) and found a messages relating to components that were installed on my old core, after replacing all the components (tedious) and changing the timezone over to what it was before, the frontend started functioning.
I still however have the problem in the backend whereby the document tree won't show and most of the menu functions won't work (JS = nothing, HTML link = blank page). Does anyone have any suggestions on how to fix the manager?
Any help is appreciated.
I had that exact same problem. This may sound obvious, but have you tried copying a fresh copy of the manager dir over your existing one?
Glad you've at least got the front end working;)
I'm still struggling with this, any suggestions?
This may not be something you'd be interested in trying, but what if you do a completely fresh install, add the necessary components to the fresh install and then restore your db...unless you've got quite a customized site?
Just a thought - I've been knocking my head against the wall with a few installs lately and got to the point where I was willing to try anything;)
All the best!