On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I can't seem to change any existing document's template since I upgraded to Revo 2.2. I also can't change new document's template either.

    When I click the template select box and change to a different template, I receive the temporary warning box. I click ok, the page reloads, but the template select box reverts back to the original template.

    Any idea what might be causing this, or a workaround to get by it?

    This question has been answered by ottogal. See the first response.

    • discuss.answer
      • Thanks ottogal, that worked. I had to set my timezone to America/Chicago in Global Settings. Strange correlation between timezone and templates, but it worked nonetheless.

        Thanks for the tip!
        • I'm running XAMPP 1.7.3 on Win 7 64 bit. Timezone in MySQL, php.ini and in the modx settings are all set to "Australia/Melbourne".. still cant change template unless doing it through quick update.

          MODX Revolution 2.2.0-pl2
          Mysql 5.1.41
          PHP 5.3.1
          System Windows NT 6.1 build 7601 ((null) Service Pack 1) i586
          • @marcushouse - Did you ever find a solution? As far as I'm concerned, I have all settings at GMT but still no luck. Just double-checked with my hosting company and they confirmed it's all at GMT. Also set GMT in System Settings in MODX

            Using:
            MODX 2.2.0-pl2
            MySQL 5.1.4
            PHP 5.2
            [ed. note: intandem last edited this post 7 years, 6 months ago.]
            • Hey there,

              Create a new php file named info.php with following code:
              <?php
              
              // Show all information, defaults to INFO_ALL
              phpinfo();?>

              and save it in the root of your website on your server. Then browse to that file in a web browser by typing http://www.yoursitename.com/info.php. You should see a php_info file that tells about all your server environment.

              Do a find for 'date' and it will go directly to date time zone. copy that value and paste it into the date_time setting inside modx manager. Problem should be solved. I have had problem and fixed with this solution on three sites... Which raises the question, "why does this problem even exist?"

              When finished delete the file.

              -N
              • Quote from: noahlearner at Mar 20, 2012, 01:16 PM
                Hey there,

                Create a new php file named info.php with following code:
                <?php
                
                // Show all information, defaults to INFO_ALL
                phpinfo();?>

                and save it in the root of your website on your server. Then browse to that file in a web browser by typing http://www.yoursitename.com/info.php. You should see a php_info file that tells about all your server environment.

                Do a find for 'date' and it will go directly to date time zone. copy that value and paste it into the date_time setting inside modx manager. Problem should be solved. I have had problem and fixed with this solution on three sites... Which raises the question, "why does this problem even exist?"

                When finished delete the file.

                -N

                Or... go to Reports > System Info and click on "View" next to phpinfo() to get a secured phpinfo only accessible when logged into the manager.


                The problem exists, for as far as I have dived into the workings of it, because of the reload. MODX stores the current form data in the cache which is identified by a timestamp. On the reload it will try to retrieve that, however if there's a discrepancy between the time as MODX sees it and the time the server thinks it is, that process will fail and it will jump back to the original template.

                That's my understanding at this point any way - I can't say I really went to the bottom of it so don't take it for granted. tongue
                  Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                  Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • Nope, I'm afraid no luck for me at all!! Have everything set to Europe/London but still won't change the template. This is wrecking my head. Am I overlooking something?

                  [ed. note: intandem last edited this post 7 years, 6 months ago.]
                  • Cleared the cache after making that change in the system settings?
                      Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                      Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                    • Tried that but no good. Should I perhaps also manually delete everything in the core/cache folder?

                      Actually, just did that and still made no difference. [ed. note: intandem last edited this post 7 years, 6 months ago.]