We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36551
    • 416 Posts
    I just upgraded revo 2.1.3-pl (traditional) with 2.2. Upgrade went smoothly, no errors, msg etc. However, I'm unable to upgrade or install any packages. I've search the forum for the error messages. Others have seen them, but are often due to cURL not being enabled. I'm in a shared hosting environment (hostmonster) where cURL is enabled and Package installations were working just fine before the upgrade. So I'm thinking this is not the issue here.

    When I select install on a particular package, it takes me to a page to where it says: Please review the license agreement for this package. However, there is no information to review. When I click continue, I get these errors.
    Could not install package with signature: wayfinder-2.3.3-pl
    
    Console running...
    Attempting to install package with signature: wayfinder-2.3.3-pl
    Package found...now preparing to install.
    Could not open file for reading: wayfinder-2.3.3-pl.transport.zip?revolution_version=Revolution-2.2.0-pl2
    MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    Could not transfer package wayfinder-2.3.3-pl.transport.zip to /home1/terrybar/public_html/revo1/core/packages/.
    Could not install package with signature: wayfinder-2.3.3-pl


    Any thoughts!
      • 3749
      • 24,544 Posts
      Check the permissions and ownership of your core/packages directory.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 36551
        • 416 Posts
        Permission is 755
          • 3749
          • 24,544 Posts
          I imagine that you tried logging out, deleting all files in the core/cache directory, and clearing your browser cache and cookies. I've had a similar problems resulting from an old cookie.

          If that doesn't do it, you could try downloading the transport.zip file, putting it in the core/packages directory and selecting Add Package and Search Locally for Packages in Package Manager.

          You might also have to remove the old package (by right-clicking on it in PM and selecting Remove Package) first.
          [ed. note: BobRay last edited this post 14 years, 8 months ago.]
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 36551
            • 416 Posts
            Bob

            Tried all of the above, no change.

            So I tried to remove one of the packages, Wayfinder, completely. The Remove button didn't work, so I removed it from the core/packages directory and the core/cache. I also removed any cookies from the site from my computer, cleared the cache on the site and in my browser, logged off and back on.

            Wayfinder is still displayed in the package manager and still is functioning on the site.

            Since this is a test site just so I can see how all this works, I'm not sure this is worth troubleshooting any further. I think I'm going to start with new site and see how it goes.

            I appreciate the help. Definitely learned more about this. Thank you!
              • 3749
              • 24,544 Posts
              Sorry that didn't work. Since you're starting over, it doesn't matter, but for future reference you should should avoid physically removing files for installed packages if possible.

              The references for the package will still be in the DB (which is why they show in PM) but will no longer be synchronized with what's in core/packages. If you tried to install the same package later, MODX could be very confused.

              Usually, if you right-click on the package and select "Remove Package" and check "Force Package Removal" it will work.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 36551
                • 416 Posts
                Bob

                Yep, I agree, removing those files is probably not a good idea. I only tried that because the force remove seemed to have no effect. It just didn't remove them.

                I imagine there was some other problem with my setup somewhere.

                I appreciate the help. Thank you!
                  • 36551
                  • 416 Posts
                  I'm still struggling with these package installations.

                  A little background. I've completed a fresh install of modx 2.2 in a folder on my shared hosted environment. I've installed some of the basic packages such as Wayfinder, Getresources etc. All indications are the site is working normally. The installation proceeded with out any errors or warning. The package installations worked just fine.

                  Now I'd like to use this installation as a the basis for a new site.

                  Zipped up the folders and files from the install above including the setup folder, but excluding the config.core.php in the root folder.
                  Exported the DB


                  In a new folder on the same server

                  Unzipped the folders
                  Run Setup as a new installation
                  Import the DB from the other site
                  Run Setup as an upgrade
                  Deleted the files in the core.cache directory
                  Deleted any cookies related to modx or the host server
                  Cleared the browser cache


                  Now, when I login to modx, the new site is working normally, the previously installed packages are there and working correctly.

                  Here's the problem. If I try to install another new package, I can find and download a package, the zip file appears in the folder with all the other packages and it is listed along with the other packages in the manager ready for install. When I attempt to install the new package it takes to an empty page where the license and other information would normally appear, but there is no data (see attachment). If I continue with the install I get the error messages show in the post previous to this.

                  Since I was able to install packages on the original installation and I'm using the same server, just a different folder, I assume the server settings (You must enable allow_url_fopen, etc.) are not an issue. Permissions on core/packages is set at 755.

                  I'd appreciate any help with this. I'm happy to provide a login to the site and/or my server if someone is willing to look around.

                  Thank you!
                    • 32316
                    • 387 Posts
                    Maybe your config file is 'confused'
                    It is here: core/config/config.inc.php
                    take a look at it, there are a bunch of paths defined there maybe one didn't make the transition
                      • 28042 ☆ A M B ☆
                      • 24,524 Posts
                      Especially tricky are the absolute URL paths, such as /assets/ which have to be changed to /subdir/assets/

                      There are also three config.core.php files that have to be edited. One in the site's root, one in /manager, one in /connectors.

                      And don't forget to delete all the folders in core/cache to force a rebuild of the cache.

                      I've also had problems with stale cookies; clear your browser cache and all cookies for the domain.
                        Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org