We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15083
    • 697 Posts
    Guys im getting the same error as Last of the Romans.
    Tried setting the date.timezone, no joy...

    Does anyone know which setting actually causes this error, and why?
      • 15083
      • 697 Posts
      Dohhh....was pointing @ the old core.
      Once I pointed to the new core...it all worked.
        • 36924 ☆ A M B ☆
        • 298 Posts
        I tried using the script myself but it was denied access to the default ini file. Here is the error:

        "Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/local/lib/php.ini) is not within the allowed path(s): (/home/:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/p142rpe2/public_html/php_ini.php on line 13
        Processing error - php.ini file not found "
          • 35150 ☆ A M B ☆
          • 191 Posts
          One other thing to check for anybody having this problem: all the url paths in core/config.inc.php ($modx_connectors_url, $modx_base_url, $modx_manager_url, $modx_assets_url)

          I ran into this problem when moving a site to a new server. phpinfo() showed proper PDO support. Rerunning setup went fine and didn't report any problems, but trying to access the site in its new location just gave this error. Turned out the problem was that I was using http://ipnumber/~username/ to access the new site since the domain name hadn't been switched, but those variables in config.inc.php were set to, for example, '/connectors/' instead of '/~username/connectors/'. I updated those and problem SLOVED ;-)
          Remember to set them back once the site has a real domain name though.
            Extras :: pThumb • Resizer • imageSlim • setPlaceholders