We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37874
    • 6 Posts
    When I click on Download Packages I get the error message: "An error occurred while connecting to the Provider: MODx received a blank response from the provider. Please double check your service URL and make sure the provider is a valid provider."

    It worked yesterday but it doesn't today even though I haven't changed any settings that I know of. cURL seems fine, the IPs are not being blocked by my host. I don't know what to do? Could the packages server be down? The following is my error report. Any ideas would be greatly appreciated. (Please note I'm not an experience ModX user so, please could you be quite detailed in explaining how to do things?)

    Kindest Regards
    Chris

    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:55] (ERROR @ /connectors/workspace/packages.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:58] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:58] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:42:59] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:53:16] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:53:16] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:53:17] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:53:17] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:56:50] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:56:50] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:56:51] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
    [2011-12-02 09:56:51] (ERROR @ /connectors/workspace/packages-rest.php) Could not connect to provider at: http://rest.modxcms.com/extras/
      • 37874
      • 6 Posts
      This is also the error that my hosting company return

      [Fri Dec 02 10:04:07 2011] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

      Also I've tried http://rest.modx.com/extras and that makes no difference.
        • 12379
        • 460 Posts
        Manually download the package and move to /core/packages. If you don't have privileges to unzip files (like myself) then also drop the unzipped directory in there (as well as the zipped package). Then go to Package Management "Add new package" and choose "Search Locally for Packages" to install the new package.
          Mostly harmless.
          • 3749
          • 24,544 Posts
          If it worked before, your host may have added or changed the mod_security settings.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 37874
            • 6 Posts
            I'm working it through with my host and they don't seem to think its a problem with the ModX install. Are there any disadvantages to installing manually? (e.g. having to upgrade the package manually)
              • 12379
              • 460 Posts
              Hard to say as I haven't had to upgrade a package yet, just uninstall (and that provides several options for retaining or deleting data and files). I'd say the automated way you're trying to achieve would be much easier though if you've got the time to resolve it.
                Mostly harmless.
                • 3749
                • 24,544 Posts
                Installing packages manually should be exactly the same as getting them though Package Manager, though it's much less convenient. The install process itself is unrelated to the download. Basically, the download just downloads the package to core/packages and puts it in the grid. Downloading manually to core/packages and searching locally for packages does the same thing.

                The only down side is that you won't get notification of available upgrades for the package in the PM grid.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 9207 ☆ A M B ☆
                  • 2,475 Posts
                  To play devil's advocate: I noticed some outages from the modx site periodically this week, and secondly, depending on your server, the package installation can get clipped by various security and permissions settings, so looking at logs in this case (e.g. mod_security logs) can be invaluable.
                    • 12379
                    • 460 Posts
                    Downloading manually to core/packages and searching locally for packages does the same thing.

                    The only down side is that you won't get notification of available upgrades for the package in the PM grid.

                    Would be a handy feature to have the upgrade notifications for manually installed packages...
                      Mostly harmless.
                      • 37874
                      • 6 Posts
                      I've seemed to have solved the problem by changing the provider, service URL from http://rest.modxcms.com/extras/ to http://rest.modx.com/extras/, then logging out and logging back in.