We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33020
    • 6 Posts
    お世話になります。
    皆さん、ご存知のことを教えてください。

    ドキュメント編集で、今まで保存が出来ていたのに、<a href="XXXXXX">ZZZZZ</a>の行を追加し保存ボタンを押すと
    コンテンツメニューはそのままで、編集欄に「Internal Server Error」と表示され、保存が出来ません。

    他のタグ(<p>、
    等)は追加保存できました。
    更に詳しく調べてみましたら、<a href=""> </a>の行追加は保存でき、<a href="http://"> </a>の行追加は保存出来ませんでした。

    サーバーのエラーログを見ましたら、File does not exist: /home/httpd/vhosts/XXXXXXX.XXX/httpdocs/images, referer: http://xxxxxxxxx.xxx/
    となっていたので、以下の記事を参考にさせていただきました。
    http://modxcms.com/forums/index.php/topic,20349.0/wap2.html
    これにより、エラーログには何も書かれなくなりました。
    上記の「Internal Server Error」を表示してもエラーログには何も記録されないということです。

    分かる方がいらしたら、教えてください。
    よろしくお願いいたします。
      • 36592
      • 970 Posts
      お力になれるかどうか分かりませんが...

      今まで問題なく動いていたものがある日突然動かなくなったということであれば、
      やはりサーバー側で何か変化があったということではないでしょうか?

      • 最近PHP/MySQLなどのバージョンアップ等はありましたか?
      • php.iniや.htaccessやmy.cnf(MySQLの設定ファイルってこんな名前でしたよね?)を編集されましたか?
      • phpMyAdmin等を使って直接「<a href="http://www...">...</a>」をコンテンツに保存することはできますか?
      如何でしょうか?
        • 33488
        • 429 Posts
        難しいところですね、Apacheのエラーログとかではでてませんかね?
        Internal Server errorってことはプログラムが落ちたとか・・もしくは、そのPOSTされたデータを拒否っているとか

        URLの記述っぽいのに反応してこけるようであれば、後者のイメージでWebサーバ側で落としてるような気もします。
        MODxのmanager周りのソースを独自修正かアップし直しミスミスとかがあればコケるかも知れませんが・・URLの記述がない場合OKだとすると・・・・・。
          • 33020
          • 6 Posts
          tkfmさん、ZeRoさん
          アドバイスありがとうございます。

          言葉足らずで、正確に伝わらなくて申し訳ありません。
          ある日突然ではなくて、ある量を超えると保存できなくなります。

          残念ながらApacheのエラーログは見方がわからないので、見れません・・・

          もう少し、調べてみましたら、<a href="http://"> </a>の同じ行を4行までの書き込みは保存できましたが、
          5行を保存しようとするとできませんでした。

          私が使用している環境だけなのでしょうか?
            • 36592
            • 970 Posts
            Quote from: yamami at Feb 21, 2008, 08:02 AM

            もう少し、調べてみましたら、<a href="http://"> </a>の同じ行を4行までの書き込みは保存できましたが、
            5行を保存しようとするとできませんでした。
            不思議な現象ですね~ 私の環境では何行でも保存できます。(当たり前か... tongue)

            もう一度「/manager」以下のファイルをアップロードし直してみるくらいしか対策が思いつきません。
              • 33488
              • 429 Posts
              5行っていうのはAタグ及びURLが入ってる場合になるということなんでしょうか?
              単純な文章5行だとOKでURL記述があるとNGっていうことであれば、なんらかのセキュリティチェックっぽい感じもしなくもないんですが・・・。
              多分、お使いの環境固有の設定なような・・・
                • 33020
                • 6 Posts
                ご連絡ありがとうございます。

                タグを入れずに、テストしてみましたら、http://だけの行を同じく4行までは保存できましたが、5行でエラーとなりました。
                環境固有の設定でしょうか?

                因みに、レンタルサーバーは使えるネットの共有サーバーを使用しています。
                もし設定の問題でしたら、具体的にどのような設定が考えられるのでしょうか?

                リンクページを作りたいのですが、この状態では、作ることが出来ません。

                お手数お掛けしますが、よろしくお願いいたします。
                  • 19033
                  • 892 Posts
                  こんにちは。

                  たぶん、ZeRoさんがおっしゃっているのは、以下のような文章の事では...?

                  あいうえお
                  かきくけこ
                  さしすせそ
                  たちつてと
                  なにぬねの

                  ↑ ただの文章

                  これが大丈夫なのに、<a>タグや、http://などが5行続くとはじかれるというのならば、
                  なにかサーバー側で、チェックがかかっているのではないか?と言う意味ではないでしょうか。。

                  たとえば、
                  <a href="http://www.xxxxx>yyy</a>
                  <a href="http://www.xxxxx>yyy</a>
                  <a href="http://www.xxxxx>yyy</a>
                  あいうえを
                  <a href="http://www.xxxxx>yyy</a>
                  <a href="http://www.xxxxx>yyy</a>

                  は、どうなのでしょう。。
                  リッチテキストエディタ使用してない状態ですよね?
                    • 33020
                    • 6 Posts
                    MEGUさん

                    ありがとうございます。

                    ただの文章でしたら、何行でも大丈夫でした。

                    http://

                    ↑この文字列を含む行が間に5行あると、保存できません。

                    <a href="http://www.xxxxx>yyy</a>
                    <a href="http://www.xxxxx>yyy</a>
                    <a href="http://www.xxxxx>yyy</a>
                    あいうえを
                    <a href="http://www.xxxxx>yyy</a>

                    ↑この場合は文字列を含む行が4行なので保存できます。

                    <a href="http://www.xxxxx>yyy</a>
                    <a href="http://www.xxxxx>yyy</a>
                    <a href="http://www.xxxxx>yyy</a>
                    あいうえを
                    <a href="http://www.xxxxx>yyy</a>
                    <a href="http://www.xxxxx>yyy</a>

                    ↑この様な場合はエラーとなります。
                    リッチテキストエディタは使用してない状態です。
                    使用した場合でも同じ現象でした。

                    サーバー側でどのようなチェックをしていると、この様な現象が起こるのか、何か考えられることはありませんか?
                      • 33014 ☆ A M B ☆
                      • 1,231 Posts
                      スパム投稿を防ぐためにサーバレベルで対策をしてることがありますね。なんというツールだったっけ。。
                      そうだとしたら、管理者さんに相談してフィルタを少し調整してもらう必要があります。