Man, this is great!!! Been waiting for something like this to come along! 5 Stars!
Followed the instructions but I get this error when I try to load the page
The template variables could not be found by the names given.
Here’s my call
Any tips?
Content Creator and Copywriter
... Also, make sure that you customize any other settings if necessary, such as the prefix for the database. The default value for the modx_table_prefix parameter is "modx_". The error message mentioned above occurs when the query for values in the template variables is empty, which could be a result of 1) no values being entered in the specified template variables, 2) searching in the wrong template variables, or 3) searching in the wrong table. Double checking your configuration parameters should solve it.
OK,
I do have a different database, so I changed one instance of it in the snippet and it’s working now.
New question:
Can I set this so that the default is to include the page in the index? I have an existing site and I don’t want to edit hundreds of pages just to make them all appear in the index.
The note in the install instructions seemed too suggest this couldn’t be done. Is that correct?
Content Creator and Copywriter
... As luck would have it, there were a couple of minor bugs in the filter for non-alphanumeric characters in the latest release (1.1), so I uploaded a corrected version as 1.1.1 (available from the same link in the above post).
If you’re specifying the terms by typing in the template variable, and you are already avoiding non-alphanumeric characters (e.g. *, ", %, +, etc.) at the beginning of the terms, you probably don’t need to upgrade. But if some of the terms have titles that start with non-alphanumeric characters, the updated filter may help with alphabetization, because the filter ignores those characters. (These characters are more likely to be an issue if you use the fallback pagetitle or menutitle fields instead of the template variable).