We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 13290
    • 6 Posts
    Firstly I would like to congratulate and commend the efforts of the Modx team and contributors for creating an amazing CMF.

    Now, here’s my problem:

    I have 2 of my own websites and several Client websites running Modx (version 0.9.6) all with 1and1 Business Hosting packages, since November 2007.

    On the 27th of February 2008 I received an email from 1and1 notifying me of a server upgrade regarding Perl, Ruby and Python. Not long after the email I was in the middle of editing content on one of my websites when the Manager failed to connect to the MySQL database and threw up an error. I closed everything down and restarted my machine just to make sure that it was not a fault from my end. After contacting 1and1, their support staff (I do not feel that they meet the criteria for ’technical’) informed me that they were aware of the problem and that it would be sorted. About an hour later the website was back online but ’not quite right’.

    1) The Wayfinder navigation was not in the order that I had set using menuindex
    2) The RSS feed, from document ’0’ was generating a ’server 500’ error (I set the feed from another document and it worked, just not from ’0’)
    3) Set to other documents the RSS feed worked but listed only in DESC order cannot be changed

    I logged into the Manager and the Document tree was listed in Document ID order and could not be changed. I contacted 1and1 and they said that there was no error on the server and that I should re-install the Content Management System. I checked the server configuration with phpinfo() and the PHP version had changed to 4.4.8 from 4.4.7 and the MySQL version from 5.0.32 to 4.0.25. I contacted 1and1 and they insisted that nothing had changed - I cross referenced my settings with all of the other websites that I have access to - which run Modx on the same 1and1 package - they were all running PHP version 4.4.8 and MySQL version 5.0.32. I tried arguing my point but to no avail. 1and1 told me that they would look into the issue and get back to me. A couple of days later I checked the server settings and the PHP version had changed back to 4.4.8 and MySQL to version 5.0.32. The problem (above) still persists and begs me to wonder whether 1and1 have corrupted the CMS or some other error has occured from the change in server settings.

    SInce this has happened to my website it has also happened to a Clients website, with the added problem of affecting Maxigallery (unable to change sort thumbnail order), DItto (RSS feed and listing of pages set with Ditto only list in Descending order).

    Basically the sorting order of all snippets and functions which rely on an ascending or descending order are defaulting to descending order only and cannot be changed. The order of the document tree cannot be changed.

    Has anyone else had this problem with 1and1?

    Should I re-install / upgrade or is there an easier solution?

    Thank you in advance.

    Modx 0.9.6
    Linux
    Apache/1.3.34
    Zend Engine v1.3.0
    PHP 4.4.8
    MySQL 5.0.32

      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Looks like they also "upgraded" the MySQL. The version released about that time has a well-known bug that causes this issue. There is no workaround.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 22303 MODX Staff
        • 10,725 Posts
        Quote from: sottwell at Mar 29, 2008, 11:25 AM

        Looks like they also "upgraded" the MySQL. The version released about that time has a well-known bug that causes this issue. There is no workaround.
        That is version 5.0.51/51a of MySQL in which those bugs exist; it should not affect MySQL 5.0.45 or earlier, but this sure does sound suspiciously like the same behavior. Are you sure that it is 5.0.32? undecided

        Quote from: J-7 at Mar 29, 2008, 11:17 AM

        Has anyone else had this problem with 1and1?
        My experiences with 1and1, via clients that insisted on using their services, was one of pure agony. If you are already dealing with those kinds of upgrade issues, mysterious configuration changes, and distance from the actual server administrators (i.e. you’re dealing with the not-so-technical support staff), I’d say your experiences are tending towards the same.
          • 13290
          • 6 Posts
          Hi,

          From phpinfo() (via System info from the Modx Manager):

          mysql
          Client API version 5.0.32

          1and1 give you an option of creating a MySQL 4 or 5 database - as the version on the server was 5.0.32 I opted for a MySQL 5 database - could the change from MySQL version 5.0.32 to 4.0.25 and back to 5.0.32 have caused incompatibility problems with the MySQL 5 database? Could this have corrupted any Modx files?

          Regards
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            The client API version is not the database version, it’s the version of the client you’re using to access the database.

            You’ll need to go to your domain’s phpMyAdmin to see the version of the database.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 13290
              • 6 Posts
              Hi Susan,

              Sorry, I may not have made myself clear on that last post.

              I created a MySQL5.0 database (I had 2 options when creating the database, MySQL4.0 or MySQL5.0).

              edit/ As with most benefiters of Modx I am a front end designer, rather than a developer, so my serverside technical knowledge has room for development and progression - which I am sure will come in time.

              Cheers

              Jamie



                • 28042 ☆ A M B ☆
                • 24,524 Posts
                Betcha it’s 5.0.51/51a, and the 4.0 is actually 4. something as well.
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Quote from: J-7 at Mar 29, 2008, 11:51 AM

                  1and1 give you an option of creating a MySQL 4 or 5 database - as the version on the server was 5.0.32 I opted for a MySQL 5 database - could the change from MySQL version 5.0.32 to 4.0.25 and back to 5.0.32 have caused incompatibility problems with the MySQL 5 database? Could this have corrupted any Modx files?
                  Wierd; I certainly wouldn’t rule out that such a switch could cause some problems with the database, as 4.0.25 and 5.0.32 are very distant releases. Of course, exactly what problems is hard to say...
                    • 13290
                    • 6 Posts
                    Susan, If you are correct then surely the other 5 websites using the same packages with the same settings would have the same problems?
                      • 23271
                      • 22 Posts
                      Hello. faced the same problem. yesterday afternoon while editing documents with the help of "Doc Manager" all sort settings fails and did not get everything back in working order: (