Are you running mod_security by any chance?
Use MODx, or the cat gets it!
-
☆ A M B ☆
- 318 Posts
I’m on a shared host on Apache, and I’m not sure whether they are running mod_security -- however, attempting to disable it in .htaccess causes the entire site to return an internal server error, so that leads me to suspect that it is not installed.
-
☆ A M B ☆
- 318 Posts
Upon further investigation, I am definitely not running mod_security. I added a rewrite to .htaccess that I know works inside a <IfModule mod_security.c> condition, and the rewrite failed.
-
☆ A M B ☆
- 318 Posts
My apologies, this was posted in the wrong section. I’m having the same issue on two separate 1.0.2 installations on the same webhost -- though, oddly, the symptom for one of these installations is different, instead of hanging, it displays the homepage in the resource editor frame. I simply never noticed it before, because I never tried to use the words "select from."
I have the same issue when i try and save anything with "onload" or "onclick" in them.
You can get round it by editing the content in your database rather than the resource/element editor, but I’d rather have a proper solution.
-
☆ A M B ☆
- 318 Posts
Hmmm... no, I don’t have any problem with "onclick" or "onload" or indeed with anything else that I can find.
I suspect it has something to do with the @SELECT binding.
Oddly, now, without any apparent change to my configuration, my 1.0.3 install is not hanging when I test this, instead it’s simply returning 404 in the edit frame.
Weird. I can simply avoid using that combination of words, but I’d like to know what causes this.
@thingstodo: I wish that were the case for me! I tried adding those commands to the .htaccess file one by one with no luck, but glad you got it sorted out!