We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7473
    • 6 Posts
    Hope this is in the right place since I’m currently running a website using Evolution 1.0.4.

    Here’s my set up if it helps:

    Modx version: Evolution 1.0.4, Traditional
    Server OS: Linux
    Server type: Public
    PHP Version: 5.2.9
    MySQL Version: 5.0.92-community
    Apache Version: 2.2.19

    Off hand I don’t know when exactly this started to happen because I haven’t logged on to the manager for a few days. But just tonight when I signed in, random parts of the manager cpanel will have the message:

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    And if I refresh, it will for example appear where the resources are listed, then if I refresh again it might be where like the manger tabs are or in the main body where I could edit resources. Or sometimes it’s completely fine after a refresh and everything shows up only to have something else disappear with the next thing I do.

    Any help or advice would be much appreciated! Please let me know if you need anymore information. Thanks!
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Check your server’s error log. Also, do you have a .htaccess file in the /manager folder? If you do, it should have no more in it than a line turning the rewrite engine off.

      You also might want to check with your hosting to see if they have recently configured or re-configured any server security modules. This is what it sounds like to me.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 7473
        • 6 Posts
        Took a look at my error log for the server and I’m seeing a lot of:

        (12)Cannot allocate memory: couldn’t create child process: /opt/suphp/sbin/suphp for (and then the directory address to the site’s index.php)

        I then took a peek at the ht.access file and there was a bit more there then just turning the rewrite engine off so I deleted what was below it and the problem was still happening.

        This was the extra bit I had by the way:

        
        <IfModule mod_security.c>
        # Turn the filtering engine Off
        SecFilterEngine Off
        </IfModule>
        
        


        Should I still contact my host about a security change? Or do you think it might be a memory problem? I don’t know very much about servers to be honest.
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          I’m sorry... that bit in your manager’s .htaccess was one of the few things that should be there. Please, put it back.

          From those error messages, it looks like you’ll need to upgrade your hosting plan to have more memory available for server processes. I’ve been in that situation a couple of times myself.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 7473
            • 6 Posts
            No problem! I put it back. grin


            Checking the error log today, there’s only a few entries:

            [Sat Aug 06 09:46:45 2011] [error] [client 141.153.173.137] File does not exist: /home/maindirectory/public_html/500.shtml,
            [Sat Aug 06 09:46:45 2011] [error] [client 141.153.173.137] (12)Cannot allocate memory: couldn’t create child process: /opt/suphp/sbin/suphp
            [Sat Aug 06 09:28:09 2011] [error] [client 141.153.173.137] File does not exist: /home/maindirectory/public_html/500.shtml,
            [Sat Aug 06 09:28:09 2011] [error] [client 141.153.173.137] (12)Cannot allocate memory: couldn’t create child process: /opt/suphp/sbin/suphp
            [Sat Aug 06 09:22:26 2011] [error] [client 67.195.112.189] File does not exist: /home/maindirectory/public_html/404.shtml
            [Sat Aug 06 09:22:26 2011] [error] [client 67.195.112.189] File does not exist: /home/maindirectory/public_html/FilingCabinet

            I don’t know if these missing .shtml files are an issue or what exactly "FilingCabinet" is. I’ve never seen that file before in my Modx directory. But that was the first thing today to throw an error.

            Thanks for all your help so far Susan. I’m webmastering for a client and I’m not too sure if they’d be up to upgrading their hosting package. I’m really hoping it’s something that can be fixed on my end you know?

            Edit: Don’t know if this is a helpful piece of information, but there’s also a Wordpress blog running on the site as well. It’s within the main directory. I checked the admin panel there and I’m not having any of the issues I’m seeing in the Modx panel.



              • 7473
              • 6 Posts
              Hi I have an update.

              Seems the memory spikes are happening every time I log in to the manager. Actually it will happen randomly also while I’m working with the manager as well.

              So what I tried is "upgrading", which was just adding the 1.0.4 install folder back into my directory and running it without installing the sample site. After that I was still getting the spikes and the internal server error message in the manager panel.

              Next I tried upgrading to 1.0.5 of Evolution, moved over all the folders that come with the download, ran an upgrade install, and I’m still getting the same error and memory spikes.

              I tried to see if I could replicate the spikes while using the WordPress admin panel and haven’t had any issues or huge memory usages with that.

              So it’s definitely Modx and the manger for some reason. I’m a bit at a loss as to what to do now since upgrading it didn’t seem to help at all.
                • 28042 ☆ A M B ☆
                • 24,524 Posts
                How many resources do you have?
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 7473
                  • 6 Posts
                  59. There’s also a test version of the entire site (built in a secondary instillation of modx, in a lower folder)in the directory as well. My client had me set this up so we could test out/review revisions (especially on already live pages) before making them live themselves, if that makes any sense.

                  So technically, if we include that too there’s 118 between the two separate versions of Modx in the main directory.
                    • 28042 ☆ A M B ☆
                    • 24,524 Posts
                    That isn’t a lot (the other site is irrelevant, unless it’s being worked on at the same time). I was just trying to figure out why the Manager would create such spikes of memory use.

                    The time I had a similar problem, I had a minimal VPS with my site and two other sites hosted on it. The problems started when one of the other sites began having a lot of development activity, while at the same time I was working on mine. One or the other of us was always getting memory errors like yours. I upgraded the VPS to the next level, and the problems disappeared.
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                      • 7473
                      • 6 Posts
                      Our host recommended that we upgrade to VPS. What really boggles my mind is the site in the past month or two hasn’t grown at all, at the most I think we added two pages and changed up some graphic content. So nothing major.
                      We’ve been with our host since February and haven’t had this problem until just recently.

                      I mean I’d be working both in Modx and our Wordpress at the same time and didn’t have these spikes as far as I know.

                      I don’t know if this is helpful, but I installed a empty new version of Modx 1.0.5 in the main directory, made a new database, and just had it install the sample site (so nothing major, no bells or whistles) and I still got the error there as well.
                      So I’m thinking it’s not anything in the directory or database that’s corrupted.