Salam!
While playing with the e1.0.5 (installed the demo content) when I simply insert an html quote (or simply any other change) in any template and save, its css files are no longer in action. I have checked the reason and find out that the templates html code lines simply have got an extra slash "\ before an every single double-quote.
I’m not sure whether it is already addressed or has been resolved.
Server: Linux // PHP 5.3.4 // MySQL 5.1.52-log
Client: Firefox 3.6.13 // Ubuntu 10.10-32bit
-
☆ A M B ☆
- 24,524 Posts
Do you have magic_quotes_gpc turned on in your PHP configuration?
yes magic_quotes_gpc is on
-
☆ A M B ☆
- 24,524 Posts
Well, that’s where it’s coming from. It needs to be off.
-
☆ A M B ☆
- 24,524 Posts
This will only work if your server is configured to use PHP as an Apache module. If it’s a CGI configuration you’ll need to use other methods; usually custom php.ini files in any directories that contain .php scripts that will be executed directly (in the case of MODx, that’s the two index.php files in the root and in the manager folder) are used for such PHP configuration overrides.
-
☆ A M B ☆
- 24,524 Posts
It all depends on your server configuration. I was just posting to advise anyone else who had the same problem but different configuration than yours. In your case, the .htaccess method is the correct one.
-
MODX Staff
- 730 Posts
MotSmart, the timezone error messages are not related to the magic quotes setting.
You do need to specify the date_timezone in your .htaccess or php.ini.
In .htaccess,
php_value date.timezone "Europe/Istanbul"
List of supported timezones:
http://php.net/manual/en/timezones.php
If you run into other php warnings, you may consider changing the error reporting level to not output warnings.
netProphET,
As you have already mentioned time-zone is just a message but the actual issue of extra slashes remained the same even after making magic_quotes_gpc to Off either by the use of .htaccess or php.ini both failed to resolve the issue.
I have noticed this sudden error on a couple of other websites in my server(even not using revo or prior versions of 1.0.5)
This is happened to one of my servers that made a major software upgrade, I’m just interested to check what have caused the error and what would be the correction since magic! does not work.