I have a document that works.
I duplicate it.
The duplicate returns a 404 error.
The i create a brand new document from scratch.
It also returns a 404 error.
What’s going on?
jealousy<>love
Looks like you have FURLS enabled. Have you checked that your .htaccess exists and is configured correctly?
Also, what do you get in your MODx error log?
.htaccess exists. i renamed it. it is located in the same directory as my modx installation. it contains:
RewriteEngine On
RewriteBase /
error log:
[2011-05-02 11:39:24] (ERROR @ /~bayviewf/modx2/connectors/lang.js.php) Could not cache context settings for mgr.
[2011-05-02 11:59:48] (ERROR @ /~bayviewf/modx2/connectors/context/index.php) modManagerLog: Attempt to set NOT NULL field item to NULL
[2011-05-02 13:17:48] (ERROR @ /~bayviewf/modx2/connectors/context/index.php) modManagerLog: Attempt to set NOT NULL field item to NULL
[2011-05-03 01:16:10] (ERROR @ /~bayviewf/modx2/connectors/element/tv.php) modTemplateVarTemplate: Attempt to set NOT NULL field rank to NULL
jealousy<>love
Try disabling FURLs and see if your pages work.
they do. i’m running Apache version 2.0.63
jealousy<>love
So all the pages work with FURLs turned off but some don’t work when FURLs are turned on?
site only contains two pages listed above. homepage doesnt count, bcuz page name is left off of url. other page (dupe of home) did not work with furls on. also tried making document from scratch (not copy of home), also did not work with furls on.
friendly-alias and friendly-alias-path both set to Yes.
jealousy<>love
That means something is probably off with your .htaccess
Try changing the line
RewriteBase /
to
RewriteBase /modx2
and then clear site cache and try again.
did not work.
shouldn’t RewriteBase be "/" if in same directory as Modx?
appreciate your help.
jealousy<>love