We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28388
    • 6 Posts
    Hey all, I’m getting a couple of errors in my error.log:
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/a563279fe6273cdb54a7d5d7429e8a38/0/ to index.php
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/a563279fe6273cdb54a7d5d7429e8a38/1/ to ht.access
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/0/ to assets
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/1/ to controllers
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/2/ to templates
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/3/ to ht.access
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not copy /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/4/ to index.php
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/736d146f30c9a124c3834f4b07ff1b39/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/185f208fe470c82465440821559d5017/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/bfc15336efa43fb298b6e6fcdf4aac56/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/bddbba0f2772d700d3cdf01f17539efb/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/709391131e00bccb7f33d9c0f87f771b/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/db365393f1ec1f786002abb2448226c4/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/5f18c1ff9ff9c91c9d3760bb73089bbe/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/9cc662119f06acb20e006f1deea6f709/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/552d60cb7c28969f77df7e9d6b17c625/ to 
    [2010-09-20 10:52:26] (ERROR @ /test/modx2/setup/index.php) Could not install files from /usr/home/********/domains/********/public_html/test/modx2/core/packages/core/xPDOFileVehicle/2de9f5217d2b2af9d703ba28c7fbaead/ to 


    Is this normal? I tried everything I can think of but I keep getting these errors in my log.
    Please met me know if this is normal as I’m completely blank on this and it’s anoying me like crazy that I can’t figure out what it is.

    Thanks!
      • 26303
      • 27 Posts
      I am getting the exact same errors on both an upgrade and a clean install on the same server.

      And I’m wondering if they are connected to my trouble getting the Provider area of Package Management to work after upgrading from 2.0 to 2.0.2 as well as in a clean install of 2.0.2. It’s first noticeable when choosing "Add New Package" and then selecting the modxcms.com provider; clicking the Next button does nothing. the "Download Extras" will open the window, but at the top of the tree it just says "Provider" and clicking on any folder results in a "Provider not specified". The modxcms.com provider is still there on the Providers tab. I’ve tried deleting that provider, clearing the cache, and recreating it, but still no luck. Interestingly, on an upgrade system if there is a "Yes" in the Updates Available column I am able to download and install a package just fine.


      Here is the environmental info:

      MODx 2.0.2-pl Traditional
      Linux 2.6.34.1
      PHP 5.2.13
      MySQL Client 5.1.48
      MySQL Server 5.1.48
      pdo_mysql 5.1.50
        • 28215
        • 4,149 Posts
        splittingred Reply #3, 16 years ago
        Quote from: SBM at Sep 20, 2010, 02:11 PM

        I am getting the exact same errors on both an upgrade and a clean install on the same server.

        And I’m wondering if they are connected to my trouble getting the Provider area of Package Management to work after upgrading from 2.0 to 2.0.2 as well as in a clean install of 2.0.2. It’s first noticeable when choosing "Add New Package" and then selecting the modxcms.com provider; clicking the Next button does nothing. the "Download Extras" will open the window, but at the top of the tree it just says "Provider" and clicking on any folder results in a "Provider not specified". The modxcms.com provider is still there on the Providers tab. I’ve tried deleting that provider, clearing the cache, and recreating it, but still no luck. Interestingly, on an upgrade system if there is a "Yes" in the Updates Available column I am able to download and install a package just fine.

        Here is the environmental info:
        MODx 2.0.2-pl Traditional
        Linux 2.6.34.1
        PHP 5.2.13
        MySQL Client 5.1.48
        MySQL Server 5.1.48
        pdo_mysql 5.1.50


        What browser/OS are you on?
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 21484
          • 23 Posts
          You get exactly the same errors as I get and wrote in this topic: http://modxcms.com/forums/index.php/topic,54521.0.html . I also have no solution for this problem until now.
            • 26303
            • 27 Posts
            splittingred,

            Browsers are Firefox 3.6.10 and IE 8.0.6, both on Vista 32.


            niepro,

            I was able to reproduce your issue, too. Saving a template in a category other than (1) will display correctly in the tree but on the edit page it always points to category (1).
              • 28215
              • 4,149 Posts
              splittingred Reply #6, 16 years ago
              Quote from: SBM at Sep 20, 2010, 04:08 PM

              splittingred,
              Browsers are Firefox 3.6.10 and IE 8.0.6, both on Vista 32.
              Did you completely clear the browser cache for each of those after upgrading?
                shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                • 26303
                • 27 Posts
                Yes, I did clear the browser caches. Here’s another wrinkle: after clearing the MODx cache, logging out, clearing the browser cache, and restarting the browser (either one), I can often get the Add New Package procedure in Package Management to work...once. When I get to the tree it still doesn’t show the modxcms.com provider name at the top--it just says "provider" (didn’t it do this before, or am I mistaken?) But I can browse the tree and download a package.

                However, the second time I go in it freezes at the Next button after I select the provider. I say that clearing everything and restarting the browser "usually" works because it’s done it 3 out of 5 tries now (again, in either browser).

                Niepro’s issue seems to happen no matter what I’ve tried so far; maybe unrelated?

                Still suspicious of those error log entries.
                  • 26303
                  • 27 Posts
                  OK, I’ve narrowed down the Provider issue in the Add New Package process.

                  When it stops working, just refreshing the page in the browser (either one) solves the problem.


                  Firefox is reporting the error as "g is undefined" in line 7 of /manager/assets/ext3/ext-all.js

                  IE is more helpful, saying "undefined is null or not an object" in line 7 character 432848
                    • 28215
                    • 4,149 Posts
                    splittingred Reply #9, 16 years ago
                    Can you detail the steps you’re taking to get this? Are you clicking on ’Download Extras’ or on "Add New Package"?
                      shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                      • 21484
                      • 23 Posts
                      I have the same issues on the Package Management as SBM, too.

                      And as I have written on the top, I get the same error logs.

                      I´ve tested it on a second PC, never before used to admin any modx system. Therefore I think it can not be a browser problem at all.

                      Hope to find a solution for that shortly.

                      What about the error logs? Does it nothing means?