I am getting the exact same errors on both an upgrade and a clean install on the same server.
And I’m wondering if they are connected to my trouble getting the Provider area of Package Management to work after upgrading from 2.0 to 2.0.2 as well as in a clean install of 2.0.2. It’s first noticeable when choosing "Add New Package" and then selecting the modxcms.com provider; clicking the Next button does nothing. the "Download Extras" will open the window, but at the top of the tree it just says "Provider" and clicking on any folder results in a "Provider not specified". The modxcms.com provider is still there on the Providers tab. I’ve tried deleting that provider, clearing the cache, and recreating it, but still no luck. Interestingly, on an upgrade system if there is a "Yes" in the Updates Available column I am able to download and install a package just fine.
Here is the environmental info:
MODx 2.0.2-pl Traditional
Linux 2.6.34.1
PHP 5.2.13
MySQL Client 5.1.48
MySQL Server 5.1.48
pdo_mysql 5.1.50
splittingred,
Browsers are Firefox 3.6.10 and IE 8.0.6, both on Vista 32.
niepro,
I was able to reproduce your issue, too. Saving a template in a category other than (1) will display correctly in the tree but on the edit page it always points to category (1).
Yes, I did clear the browser caches. Here’s another wrinkle: after clearing the MODx cache, logging out, clearing the browser cache, and restarting the browser (either one), I can often get the Add New Package procedure in Package Management to work...once. When I get to the tree it still doesn’t show the modxcms.com provider name at the top--it just says "provider" (didn’t it do this before, or am I mistaken?) But I can browse the tree and download a package.
However, the second time I go in it freezes at the Next button after I select the provider. I say that clearing everything and restarting the browser "usually" works because it’s done it 3 out of 5 tries now (again, in either browser).
Niepro’s issue seems to happen no matter what I’ve tried so far; maybe unrelated?
Still suspicious of those error log entries.
OK, I’ve narrowed down the Provider issue in the Add New Package process.
When it stops working, just refreshing the page in the browser (either one) solves the problem.
Firefox is reporting the error as "g is undefined" in line 7 of /manager/assets/ext3/ext-all.js
IE is more helpful, saying "undefined is null or not an object" in line 7 character 432848
Can you detail the steps you’re taking to get this? Are you clicking on ’Download Extras’ or on "Add New Package"?
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
I have the same issues on the Package Management as SBM, too.
And as I have written on the top, I get the same error logs.
I´ve tested it on a second PC, never before used to admin any modx system. Therefore I think it can not be a browser problem at all.
Hope to find a solution for that shortly.
What about the error logs? Does it nothing means?