We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31504
    • 16 Posts
    victorjonsson Reply #1, 16 years ago
    Good day.

    I’ve just upgraded from 2.0.0-pl to MODx Revolution 2.0.2-pl as per the upgrade instructions in the documentation. I uploaded the files and run setup without any problems.

    But I’m having a few problems in the manager:


    I’ve tried...

    • I’ve cleared my browser cache
    • I logged out of the manager before running setup
    • I’ve flushed permissions and sessions in the manager

    Environment

    • Linux server running Apache (I don’t know the versions for those)
    • MySQL 5.0.91-community
    • PHP Version 5.2.14
    • This is a shared hosting environment and PDO is enabled.

    2.0.0-pl was running fine, other than that I could not get thumbnails to show in the resource browser.
      Freelance Multimedia Designer
      MODx - Wordpress
      www.victorjonsson.dk
      • 28215
      • 4,149 Posts
      splittingred Reply #2, 16 years ago
      - Any JS errors?
      - Was this the traditional or advanced 2.0.2 you used?
      - Any errors in core/cache/logs/error.log?
        shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
        • 31504
        • 16 Posts
        victorjonsson Reply #3, 16 years ago
        Hi splittingred.

        The manager magically works now. I hadn’t checked since I wrote here on the forum.

        No idea why. Maybe it was something that didn’t get cleared from some cache.


        • I didn’t notice any JS errors
        • This was the traditional install
        • There are some json_encode and file copying errors in the log (it’s attached to this post)

        I still haven’t gotten image thumbnails to work in the resource manager though.
        In the error log is written:
        (ERROR @ /~site/connectors/system/phpthumb.php) Error outputting thumbnail:
        OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 557

        Thanks for the help
          Freelance Multimedia Designer
          MODx - Wordpress
          www.victorjonsson.dk
          • 24414
          • 45 Posts
          Hiya–

          I seem to have the same problem here– missing class key (can’t save when input either) as well as no template variables showing.

          Upgraded from 2.0.0pl to 2.0.2 (Traditional).

          Linux/Apache
          PHP5.2.14
          MySQL 5.0.91-community
          PDO installed


          No JS errors as far as I can see.

          Error logs shows up a few things though…

          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/a563279fe6273cdb54a7d5d7429e8a38/0/ to /home/dev/index.php
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/a563279fe6273cdb54a7d5d7429e8a38/1/ to /home/dev/ht.access
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/0/ to /home/dev/manager/assets
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/1/ to /home/dev/manager/controllers
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/2/ to /home/dev/manager/templates
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/3/ to /home/dev/manager/ht.access
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not copy /home/dev/core/packages/core/modContext/6f6ce5455726d691ef59d605e51595ab/4/ to /home/dev/manager/index.php
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/736d146f30c9a124c3834f4b07ff1b39/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/185f208fe470c82465440821559d5017/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/bfc15336efa43fb298b6e6fcdf4aac56/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/bddbba0f2772d700d3cdf01f17539efb/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/709391131e00bccb7f33d9c0f87f771b/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/db365393f1ec1f786002abb2448226c4/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/5f18c1ff9ff9c91c9d3760bb73089bbe/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/9cc662119f06acb20e006f1deea6f709/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/552d60cb7c28969f77df7e9d6b17c625/ to /home/dev/connectors/
          [2010-09-20 23:13:49] (ERROR @ /setup/index.php) Could not install files from /home/dev/core/packages/core/xPDOFileVehicle/2de9f5217d2b2af9d703ba28c7fbaead/ to /home/dev/connectors/

            • 28215
            • 4,149 Posts
            splittingred Reply #5, 16 years ago
            Did you try clearing your browser cache?
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 24414
              • 45 Posts
              Right–

              I cleared the browser cache (OS X Safari 5.0.2) a couple of times last night to no avail. This morning these issues were not present in Firefox, and on restarting Safari this morning the issue was not evident either…

              Thanks
                • 31504
                • 16 Posts
                victorjonsson Reply #7, 16 years ago
                It was a bit strange for me too.

                I cleared the browser cache and flushed the MODx cache and sessions, but it didn’t work.

                Two days later it just worked. Must be some webhost cache issue.
                  Freelance Multimedia Designer
                  MODx - Wordpress
                  www.victorjonsson.dk
                  • 14162
                  • 67 Posts
                  Was having the same issue after 2.0.2 upgrade - template variables absent on the resource editor. What worked for me was refreshing the browser when on the empty Template Variable tab. All the TVs suddenly appeared.

                    • 3496
                    • 101 Posts
                    I had the same issues, but indeed a refresh on the template tab seemed to help.

                    But:
                    the Published and Hide from Menus checkboxes were still not visible after that.

                    And another issue: editing existing resources didn’t work anymore; I got a New Document form with the resource-ID (correctly) filled in - but everything else empty. For the details: the template was emtpy, but the right template variable was shown on the template-tab (showing no content of course). On the page settings the class key was empty again (and shown in red). And Tiny MCE was not shown.
                    This was all while using Google Chrome - and all the problems went away after a refresh on the main edit-page.

                      • 14349
                      • 44 Posts
                      This happened to me - cleared the cache and it seemed to fixed itself after a day or so

                      Everything is cool now working on Linux Centos