We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 29076
    • 615 Posts
    After upgrading to 2.01 I get errors on saving:

    1. The selected template disappears from the list, and the template field is blank.

    2. The new parameter Class Key is not stored, so I have to set this parameter every time I save the document.

    3. The document is always moved to the root directory. It does not remain in the folder it was originally stored in.

    One more question: What is the Class Key, what are the parameters and modDocument modResource and how is it possible to read about this?

    Info: I upgraded from Revo 2.00pl to 2.01pl, Traditional, and I have uploaded the files twice, to be sure.

    PHP Version 5.2.14
    MySQL 5.1.49-log
    Linux


    Thanks.
      I think, thererfor I am! But what I am, and why...?
      • 33987 ☆ A M B ☆
      • 197 Posts
      Same problems here.

      I partially fixed it by:
      - clearing the cache
      - flushing the permissions


      I now however have the issue that some fields aren’t saved correctly:
      - long title
      - introtext

      If I save a document they disappear. If I click on the document in the document tree after saving I DO see the changes. So somehow they are saved, but they don’t show. I have to reload the document.
        Sterc Internet & Marketing | MODX Founding Partner | Chairman of the MODX Advisory Board

        In need of a MODX consult? Try our MODX Developers Experts!
        • 14349
        • 44 Posts
        Also getting this error -

        Along with the above - all my front end blog posts display html tags unparsed in just plaintext



        edit ....

        To be more specific - When you create a document it does not auto input the document Class Key - it clears the template of some documents as well.
          • 28215
          • 4,149 Posts
          splittingred Reply #4, 16 years ago
          These are known issues that somehow skirted through testing. We’ll have 2.0.2 out in the next day to resolve these issues. *Many* apologies for this.
            shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
            • 33987 ☆ A M B ☆
            • 197 Posts
            Awesome, thanks for the quick fix!
              Sterc Internet & Marketing | MODX Founding Partner | Chairman of the MODX Advisory Board

              In need of a MODX consult? Try our MODX Developers Experts!
              • 14349
              • 44 Posts
              Normally my frustrated hat would be on - however when it comes to the Modx team my frustrated hat turns into a beanie.

              You guys are great ...

              Now I HOPE everyone remembered to back up their database before upgrading : )
                • 27672
                • 168 Posts
                slush puppie Reply #7, 16 years ago
                "backup"?? what is the meaning of this word? tongue
                  • 29076
                  • 615 Posts
                  Quote from: Sylvaticus at Sep 17, 2010, 05:20 AM


                  3. The document is always moved to the root directory. It does not remain in the folder it was originally stored in.

                  Thank you so much for a very quick fix. I’ve upgraded to 2.02. smiley But in my case there’s still one error, the document is moved to the root folder after saving.
                    I think, thererfor I am! But what I am, and why...?
                    • 28215
                    • 4,149 Posts
                    splittingred Reply #9, 16 years ago
                    Quote from: Sylvaticus at Sep 17, 2010, 02:20 PM

                    Thank you so much for a very quick fix. I’ve upgraded to 2.02. smiley But in my case there’s still one error, the document is moved to the root folder after saving.

                    I can’t replicate that at all:

                    - Do you have any wierd plugins?
                    - Any RTEs?
                    - Does this happen in any browser?
                    - Did you upgrade with traditional or advanced?
                    - Did you clear the browser cache?
                    - Any errors in core/cache/logs/error.log?
                      shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                      • 29076
                      • 615 Posts
                      Thank’s for the reminder, it was the Browser cache in Firefox. smiley It’s all OK now.
                        I think, thererfor I am! But what I am, and why...?