Upgraded to 2.1 - but now, upon logging into the manager, I see ’access denied’ everywhere. The file tree, and anything I try to edit. Can’t even Log Out - "Access Denied"
Does anyone know what I can do to fix myself?
Ok, so I admit, I didn’t read the warning on the ’upgrade instructions’ until after trying to install Rev 2.1. I’m assuming the problem has something to do with my non-updating packages.
Thanks!
Hello, I have the same trouble. Can’t figure out what to do. In DB all seems correct (I checked the modx_member_groups, modx_user_group_roles, modx_users... can’t find any error there.)
Please help me, the stupid.
Thanks.
<em>The Earth is not the hell, and people aren't cursed, and joy in not a sin, but a gift of God.</em> (Lesia Ukrainka)
I wish I could be of more help - but I’ve tried upgrading this particular installation of MODx several times. (Like 5 times)
I’ve resorted to rebuilding the site in a fresh installation of MODx. Really time consuming.( I just hope that this isn’t something that happens with every upgrade.)
Sorry...
It shouldn’t have anything to do with packages and I don’t think those error messages are relevant.
The first thing to try is deleting all the files in the core/cache directory and clearing your browser cache and cookies.
If that doesn’t work, it usually means that either:
1. Some files didn’t get overwritten when you transferred them.
2. Some file and/or directory permissions (or ownership) got changed in the file transfer.
3. One or more files was corrupted or missing in the file transfer.
On reflection, what I said about packages wouldn’t apply if you have plugins that operate in the Manager. An outdated plugin could possibly cause your symptoms.
I would update all plugins that have updates. If that doesn’t do it, try disabling them all and clearing the cache, and if that fixes it, turn them back on one-by-one until you find the culprit.
@BobRay -
Neat! Will try that.
Quote from: Romain at Jul 11, 2011, 01:47 AM
Hi,
I had the problem on my side here. The problem was because of a plugin to switch contexts according to the host (see http://modxcms.com/forums/index.php/topic,66479.0.html).
Going through the db and desactivating the culpit plugin solved the problem.
Cheers
Thanks Romain. My problem was exaclty this.
Thank to all you guys for replying.
<em>The Earth is not the hell, and people aren't cursed, and joy in not a sin, but a gift of God.</em> (Lesia Ukrainka)