-
☆ A M B ☆
- 2,475 Posts
Weird stuff.... when I updated my site to 2.1-pl, my CMP’s all kinda broke: the HTML is all there, but I can’t scroll down on the page... so they are working, but I can’t actually see them or save them. I tried just printing a bunch of Lorep Ipsum text in there and I removed all my custom CSS from the CMP (regClientCSS commented out) and the behavior continues.
Anyone got any ideas what might be going on?
JS error - same thing happens, except it happens when I go to System Info
2.1
centos 5.5
php 5.3.6
mysql 5.0.77
Only errors seen through firebug
-
☆ A M B ☆
- 2,475 Posts
I’m not seeing any errors in FireBug... but this is becoming a huge problem because we can’t use our custom tools. The most obvious explanation here is that some of the manager CSS changed from 2.0.8 to 2.1.0.
There are now seperate scrollbars for the tree-panel and the content-panel, which is way better than it was before with one scrollbar for all and it solves an issue with positioning and dragging on firefox.
If you need extra scrollbars in your custom-CMP, I think you need to add them where necessary.
-
☆ A M B ☆
- 872 Posts
It i snecessary because of the reason mentionned in the issue 4656.
The manager layout use an Ext Viewport with a border Layout, therefore, all resizing should be handled by the Ext layout (that’s why the main manager layout as an option autoScroll set to true).
If you render your text or anything else without using the ext layout manager, ext does not apply the correct resizing (it can be resize event - hence why the grid never resized correctly - , or in this case, no scroller bar).
The real solution would be to not use a border layout in the next manager version and handle positioning with CSS directly. Until then...