-
MODX Staff
- 730 Posts
As far as issues I’ve worked on for the Evo 1.0 RC, It’d be great it anyone could give the following some scrutiny:
- reskinned installer - look for any browser glitches or usability concerns
- creating new elements with duplicate names not allowed (from the "New [Templates|TV|Chunk|Snippet|Plugin|Module]..." screens only - you can still create duplicate-named elements in other ways) - look for any bugs or usability problems with the error handling resulting from trying to create an element with a duplicate name
- document access permissions - some changes have been made regarding where users can create documents and what permissions they are allowed to set - best thing would be to test the kinds of permission/access scenarios you might normally use or expect others to use - see the following for specifics
[list]
[li]http://svn.modxcms.com/jira/browse/MODX-410
- http://svn.modxcms.com/jira/browse/MODX-397
- http://svn.modxcms.com/jira/browse/MODX-516
[/li]
[/list]
Thanks
-
☆ A M B ☆
- 24,524 Posts
No problems with installer here; both a new installation (local) and upgrading my remote site. One thing about the installer, though. I mentioned some time ago that the page requiring accepting the license isn’t necessary for GPL licensed applications; I had thought that page was going to be removed.
The duplicate element error seems to be working fine for me as well. This is FF 3.0.10 OS X. Works OK on Safari as well (actually seems to work faster on Safari).
working good for me...nice error messages. I did not test the doc permission setup yet.
I just did my first installation of 1.0.0-RC1 and the (fresh) install process went fine and I like the new look, but I had some strange login issues afterwards. First, the username in the Manager login form kept resetting to all lowercase, which made the login fail. So I edited the database and changed my username to all lowercase, and the login still failed. I had to also enter a new password (MD5-encrypted) in phpMyAdmin to be able to login to the Manager. I’m pretty certain that I didn’t mistype my password, but I suppose that it’s possible. Has this happened to anyone else?
When I try the login in Opera instead of Firefox the username does not reset to lowercase on blur, which made me think that it was a Firefox saved passwords issue. What’s odd is that all of my saved MODx usernames are uppercase ZAP, and I never have this problem on a multitude of 0.9.6 instalations. Anyone know what might be going on?
If the username is being reset to lowercase purposefuly, then a) I don’t want it to do that but b) if it does that, it needs to be enforced in the installer and Manager User panel as well (and I would say that the posted username should be converted to lowercase server-side after the post, not before, which makes login fail).
-
☆ A M B ☆
- 24,524 Posts
I have no problem with upper case usernames. No changes, no difference in behavior from lower case or mixed case. (FF 3.5/OS X)
I did a clean install in IE7/Vista Ultimate. The only quirk I could see is that WebLoginSidebar is reported as upgraded rather then installed (I did choose to install the sample site and all add-ons). Otherwise, it was completely smooth.
I also did an upgrade install with Chrome/Vista Ultimate with no problems.
I had no trouble with a mixed-case password in either IE7 or FF3 on Vista.
Quote from: sottwell at Jul 04, 2009, 11:42 PM
I have no problem with upper case usernames. No changes, no difference in behavior from lower case or mixed case. (FF 3.5/OS X)
So this is just happening to me, I guess. It’s very odd, but it seems to be a Firefox 3.5.1 (Linux) saved fields issue of some sort. It turns out that I can enter another mixed-case or uppercase username - just not "ZAP".
Glad to know that this is not intended behavior!
-
☆ A M B ☆
- 24,524 Posts
The upgrade to my site did rather rudely change my Manager theme to MODxCarbon. A nice theme, but I like my own IcedWine better
-
☆ A M B ☆
- 24,524 Posts
Yes, they still work, but the upgrade updated the database to use MODxCarbon instead of the one I was using. It was easy enough to go to the configuration and change it back; it just seemed that it should have left my existing settings alone.