We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 359
    • 3 Posts
    The online documentation contains a tutorial by Sottwell on how to setup a basic news or blog site. On the face of it, it seems easy to follow and do, but unfortunately not all preconditions are met by the current standard distribution. According to the install.txt file the following snippets should be installed in advance:

    FlexSearchForm-
    PageTrail-
    DropMenu-
    ...
    NewsListing-
    UserComments-

    These neither seem to be in the 0.9.5 zip file, nor in the repository.

    Is there anywhere else these can be found or are they depreciated and in that case: Is there a way to convert the tutorial to whatefter has succeeded these snippets?

    /Allan
      • 25663 MODX Staff
      • 12,272 Posts
      AjaxSearch replaces FlexSearchForm.

      Breadcrumbs replaces PageTrail.

      Wayfinder replaces DropMenu.

      Ditto/Jot replaces Newslisting/UserComments.
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 359
        • 3 Posts
        Thank you. I’ll see if I can work may way through the tutorial with these replacements. Can I expect the parameters of the new snippets to be compatible with the old ones which Sottwell describes?
          • 33337
          • 3,975 Posts
          They are more or less same, expect couple of changes but you can easily spot them, be sure to read the readme/install file and the help given on download page.

          regards.
            Zaigham R - MODX Professional | Skype | Email | Twitter

            Digging the interwebs for #MODX gems and bringing it to you. modx.link
            • 10076
            • 1,024 Posts
            Quote from: Achrist at Jan 21, 2007, 08:29 AM

            Thank you. I’ll see if I can work may way through the tutorial with these replacements. Can I expect the parameters of the new snippets to be compatible with the old ones which Sottwell describes?

            Did you manage to get a blog up and running? Could you post the way you did this?
              • 19554
              • 59 Posts
                • 11614
                • 27 Posts
                Hi!

                I have a minor (?) problem with the blog: I cannot make any comments because of some strange MySQL error (MODx parse error...You have an error in your SQL syntax near...). I have checked the syntax (you know, backticks smiley), but it did not work. I checked a thousend
                times to have everything exactly as it was in the tutorials, descriptions. Could you help me how to solve this problem please?
                I have a modx 0.9.5 installed.
                Thx in advance.

                H.M
                  • 33372
                  • 1,611 Posts
                  Can you post the error here (including the bad MySQL query)? If we can see that we can tell what is wrong with the query, and from there it may be possible to figure out the cause.
                    "Things are not what they appear to be; nor are they otherwise." - Buddha

                    "Well, gee, Buddha - that wasn't very helpful..." - ZAP

                    Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
                    • 11614
                    • 27 Posts
                    Hi!

                    Here is the error message:

                    « MODx Parse Error »
                    MODx encountered the following error while attempting to parse the requested resource:
                    « Execution of a query to the database failed - You have an error in your SQL syntax near ’’ at line 1 »
                    SQL: UPDATE `btrend`.bart_jot_content SET title=’Hedlájn szábdzsekt’,content=’kommentje a hedlájnnak, átmegy?’,createdon=’1177619141’,createdby=’-6’,secip=’84.1.208.147’,sechash=’54df5600262389358be5b7628b8f9d17’,uparent=’42’,tagid=’’,published=’1’ WHERE id=;
                    [Copy SQL to ClipBoard]

                    Parser timing
                    MySQL: 0.1609 s (17 Requests)
                    PHP: 0.2446 s
                    Total: 0.4055 s


                    I was investigating this problem a bit, the message appears now only when I try to send the comment while logged in. When I send it as guest it does not do anything only thet it redirects me to the main page.
                    Yesterday it was the opposite (error when sending as guest, and redirection when sending as a registered user). I don’t get the point... undecided
                    The commentschunk is:

                    <div id="commentsAnchor">
                    [[Jot? &customfields=`name,email` &subscribe=`1` &pagination=`4` &badwords=`dotNet` &canmoderate=`Site Admins` ]]
                    </div>

                    First I used this chunk (but it did not work):

                    [!Jot? &subscribe=`0` &pagination=`10`!]
                      • 33372
                      • 1,611 Posts
                      There seems to be an error in Jot’s SQL syntax (note that there is no id at the end of the query). What version of Jot are you using? I would upgrade to the latest version, and if that doesn’t fix the problem then you should post a message to the Jot forum (where the folks who really know the ins and outs of Jot dwell).
                        "Things are not what they appear to be; nor are they otherwise." - Buddha

                        "Well, gee, Buddha - that wasn&#39;t very helpful..." - ZAP

                        Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options