New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi there,

    I am trying to get a new MODx site set up - but I get this error:

    FATAL ERROR: MODx Setup cannot continue.

    Make sure your PHP session configuration is valid and working.

    The site is on a VPS server, on which I have another site running perfectly sith the same php.ini file so I have no idea what’s happening.

    PHP is running as a CGI module rather than an Apache module.

    Any help very gratefully received!

    Jim.

    Here is the phpinfo() output:

    Configuration
    PHP Core
    Directive Local Value Master Value
    allow_call_time_pass_reference Off Off
    allow_url_fopen Off Off
    allow_url_include Off Off
    always_populate_raw_post_data Off Off
    arg_separator.input & &
    arg_separator.output & &
    asp_tags Off Off
    auto_append_file no value no value
    auto_globals_jit On On
    auto_prepend_file no value no value
    browscap no value no value
    default_charset no value no value
    default_mimetype text/html text/html
    define_syslog_variables Off Off
    disable_classes no value no value
    disable_functions no value no value
    display_errors Off Off
    display_startup_errors Off Off
    doc_root no value no value
    docref_ext no value no value
    docref_root no value no value
    enable_dl On On
    error_append_string no value no value
    error_log no value no value
    error_prepend_string no value no value
    error_reporting 6135 6135
    expose_php Off Off
    extension_dir /usr/lib/php/modules /usr/lib/php/modules
    file_uploads On On
    highlight.bg #FFFFFF #FFFFFF
    highlight.comment #FF8000 #FF8000
    highlight.default #0000BB #0000BB
    highlight.html #000000 #000000
    highlight.keyword #007700 #007700
    highlight.string #DD0000 #DD0000
    html_errors On On
    ignore_repeated_errors Off Off
    ignore_repeated_source Off Off
    ignore_user_abort Off Off
    implicit_flush Off Off
    include_path .: .:
    log_errors On On
    log_errors_max_len 1024 1024
    magic_quotes_gpc Off Off
    magic_quotes_runtime Off Off
    magic_quotes_sybase Off Off
    mail.force_extra_parameters no value no value
    max_execution_time 120 120
    max_file_uploads 20 20
    max_input_nesting_level 64 64
    max_input_time 60 60
    memory_limit 128M 128M
    open_basedir no value no value
    output_buffering 4096 4096
    output_handler no value no value
    post_max_size 16M 16M
    precision 14 14
    realpath_cache_size 16K 16K
    realpath_cache_ttl 120 120
    register_argc_argv Off Off
    register_globals Off Off
    register_long_arrays Off Off
    report_memleaks On On
    report_zend_debug On On
    safe_mode Off Off
    safe_mode_exec_dir no value no value
    safe_mode_gid Off Off
    safe_mode_include_dir no value no value
    sendmail_from no value no value
    sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
    serialize_precision 100 100
    short_open_tag On On
    SMTP localhost localhost
    smtp_port 25 25
    sql.safe_mode Off Off
    track_errors Off Off
    unserialize_callback_func no value no value
    upload_max_filesize 16M 16M
    upload_tmp_dir no value no value
    user_dir no value no value
    variables_order EGPCS EGPCS
    xmlrpc_error_number 0 0
    xmlrpc_errors Off Off
    y2k_compliance On On
    zend.ze1_compatibility_mode Off Off
    • hi,

      the error speaks about session and you haven’t given us any session params... smiley

      something you could have a look at, the session temp dir. Some configurations need you to create a session dir in you website root dir to store sessions tmp files, mays be it could be the case. If so, without that dir, modx session (well any session) can’t work

      (prefer session use trans sid on 0 too)

      have swing
        réfléchir avant d'agir
      • Jim,
        I had the same exact issues. It took me forever to figure out how to fix it. I had just upgraded our PHP version to include PDO support. After doing so, session.auto_start had been set to 0. I have a VDS so I just went in to the WHM and updated the PHP configuration (under advanced settings) and changed session auto start to 1. Then restarted apache and restarted mysql (just in case). The errors went away and I finished the setup with no more issues. Good luck!
        Tom
        • Hi,

          Sorry to dig this old thread but I have the same session error with the install of modx revolution.
          I have tried the session.autostart = 1 thing but it doesn’t seem to change anything.
          And I really don’t know what the correct session configuration should be... huh

          Thanks for any suggestion...

          My configuration (Local server):

          arch linux
          nginx
          php-fpm
          mysql ..
          modx revo

          "/tmp" is "world writable".

          Session Support enabled
          Registered save handlers files user
          Registered serializer handlers php php_binary


          Sessions info from php_info:
          Directive Local Value Master Value
          session.auto_start On On
          session.bug_compat_42 Off Off
          session.bug_compat_warn Off Off
          session.cache_expire 180 180
          session.cache_limiter nocache nocache
          session.cookie_domain no value no value
          session.cookie_httponly Off Off
          session.cookie_lifetime 0 0
          session.cookie_path / /
          session.cookie_secure Off Off
          session.entropy_file no value no value
          session.entropy_length 0 0
          session.gc_divisor 1000 1000
          session.gc_maxlifetime 1440 1440
          session.gc_probability 1 1
          session.hash_bits_per_character 5 5
          session.hash_function 0 0
          session.name PHPSESSID PHPSESSID
          session.referer_check no value no value
          session.save_handler files files
          session.save_path /tmp /tmp
          session.serialize_handler php php
          session.use_cookies On On
          session.use_only_cookies On On
          session.use_trans_sid 0 0
          • huh

            Finally it is working...

            I am not sure what fixed it but still here is what I’ve done:
            I just erased all sessions files in /tmp (wich I already did before), cleared the session cookie for my domain in firefox (which I didn’t do before), went back to the homepage and then to setup... seems to work!

            laugh
            • Quote from: holotrope at Aug 20, 2010, 08:29 PM

              changed session auto start to 1

              In fact this caused me a white screen of death when I tried to login to the manager (just after installation)...
              • when you are running PLESK and have PHP as "fastCGI" look here for a solution

                http://forums.modx.com/thread/28834/revolution-install-problem#dis-post-396734
                • I fixed this problem by creating the "tmp" folder to my root folder. I'm don't know about any other settings of mine, but this one little folder "/tmp" fixed this output.
                  • I had an similar issue when running the update setup. Unfortunately the php user had now write access to the php session directory.
                    chmod -R nginx:nginx /var/lib/php/session/

                    This fixed my problem.
                    https://www.sofasurfer.org/blog/2017/05/03/fatal-error-modx-setup-cannot-continue/


                      Home is where the hard disk is:
                      http://sofasurfer.org