On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Quote from: iusemodx at May 03, 2016, 10:02 AM
    A workaround for the alias - not tested but should work

    Update your config:
    Tools => Configuration => Friendly URLs Tab

    Select Yes for the following:

    • Allow duplicate URL aliases
    • Automatically generate URL alias

    Then save the settings

    Now got to the DocManager ans select the "Other Properties" tab (As describe previously)

    Click in the "Edited On Date:" and select todays date.

    In the field "Specify a Range of Document IDs" add your parent ID with ** and then click the submit button

    example:

    22**

    This is realy cool, I published all of them, thank you.

    Not sure why, but in my case alias adds only if I click 'Save' directly in the editing page. And also page appear on site only if I click 'Save', but I can access page if I click 'View' on editing page.
    • I've updated the post title to reflect the question.
      • As stated in my previous post - I hadn't tested it smiley

        You might want to try other strategies / settings, that might get you a better result - but I think in the meantime, that solution is at least a starting point
        • Quote from: iusemodx at May 03, 2016, 10:02 AM
          A workaround for the alias - not tested but should work

          Update your config:
          Tools => Configuration => Friendly URLs Tab

          Select Yes for the following:

          • Allow duplicate URL aliases
          • Automatically generate URL alias

          Then save the settings

          Now got to the DocManager ans select the "Other Properties" tab (As describe previously)

          Click in the "Edited On Date:" and select todays date.

          In the field "Specify a Range of Document IDs" add your parent ID with ** and then click the submit button

          example:

          22**

          My fault, that works perfectly. I deleted old branch and duplicated new and now I have all aliases. Thanks for your help!

          Upd: but somewhy I still can't see those pages at the site. They exists, but they are not in catalog.
          • Mabye there is some special database parameter that allows to show pages? I can see them just when I click on 'Save'.

            Upd: I found that 'Save' button launches '/manager/processors/save_content.processor.php' file. Mabye anywhere here will be an answer. [ed. note: anotherplace last edited this post 5 years, 7 months ago.]
            • Try re-naming the duplicate parent alias (folder containing the new 1000) - just as a test, then clear all cache and look at the front-end

              You might be having conflicts due to duplicate aliases
              • Quote from: iusemodx at May 03, 2016, 01:00 PM
                Try re-naming the duplicate parent alias (folder containing the new 1000) - just as a test, then clear all cache and look at the front-end

                You might be having conflicts due to duplicate aliases

                Unfortunately it didn't help. I almost found what to do, I found that just after 'OnDocFormSave' pages appear on site. And now I can't find where 'OnDocFormSave' came from. I even made a new question for it.