On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Bonjour,
    je viens d’installé MODX 2.1.1 et je ne comprends pas pourquoi, je n’arrive pas séelectionner des image que j’ai uploader sur le serveur.
    ä la racine de mon site, j’ai créé un dossier /images ou j’y ai mis des images. Ensuite je les ai uploader sur mon serveur.

    Ce que je ne comprends pas, c’est depuis mon TinyMCE, quand je clique sur l’icone pour y ajouter une image, je vois l’arborescence, ou je retouvre mon dossier /images. Quand je clique sur ce dernier, je ne vois pas mes images (qui sont bien sur le sereur).

    Pourquoi je ne les vois pas...

    Aussi j’ai aussi une autre question.
    Comment puis donner la possibilité à une utilisateur (collaborateur( le droit de modifier une page seulement?

    Merci pour vos lumières
    • Il semblerait que j’ai le même problème, en faite, si c’est exactement le même problème, c’est que du côté gauche on voit la structure des dossiers, et sur la partie droite le contenu de chaque dossier, mais pour une raison que j’ai (en partie) compris, cette zone n’est pas rafraîchit, la raison ? il semblerait que cela soit un problème de droit !

      D’autres personnes ayant ce problème ?

      Ci-joint un petit montage/capture écran de ce que j’ai.
        Low
      • Effectivement, après avoir testé de mon côté, le problème est également présent…
        Une issue a été ouverte sur Github

        Petite question, avez-vous personnalisé l’option système filemanager_path ? (de mon côté elle l’est)
        • Quand j’ai "oser" le faire (tout à l’heure), modx m’a renvoyer dans les roses, donc non, pour ma part, l’absence de ce paramètre n’empêche en rien son fonctionnement (du moins sur mon serveur), d’ailleurs, l’onglet Fichier à gauche fonctionne bien quand à lui.

          D’autres posts relatifs au même problème, mais sans aucune résolution, sauf virer le cache du navigateur (mfff, j’ai essayé... nope)

          http://modxcms.com/forums/index.php/topic,63523.msg369379.html#msg369379
          http://modxcms.com/forums/index.php/topic,65521.msg370097.html#msg370097

          C’est un problème assez grave dans le sens ou aucun de mes clients ne pourront utiliser ce bouton pour rajouter des photos, ce qu’ils font en général, ...
            Low
          • En fait, si je comprends bien le post de ton premier lien (j’ai lu en diagonale), il faut plutôt corriger manuellement quelques fichiers (les modifications apportées par ce commit), utiliser les nouvelles versions de modext-min.js et modext.js *et* ensuite vider le cache (Revo comme navigateur).

            Vu que les versions de dev n’ont pas leurs fichiers JS minifiés, je suppose que c’est pour cela que l’auteur du post change également son option compress_js…

            J’espère que cela pourra aider les courageux qui souhaitent faire les modifs manuellement ^^
            • Je vais, en regard de ton dernier commentaire sur https://github.com/splittingred/TinyMCE/issues/65, appliquer ces modifications(recommandation?), je vais faire un retour d’xp pour vous dire si cela à résolu le problème.
                Low
              • Bon, premier retour négatif, mais voilà ce que j’ai fait:

                fichier:ligne modifié

                manager/assets/modext/widgets/core/modx.rte.browser.js:109
                            ,wctx: MODx.ctx
                


                manager/controllers/default/browser/index.php:23
                MODx.siteId = "'.$_SESSION["modx.{$modx->context->get('key')}.user.token"].'";
                


                Destruction du cache revo -> deconnexion -> suppression du cache navigateur (chrome) -> reconnexion.

                Cela n’a pas fonctionné, à moins que j’ai raté une étape ?
                  Low
                • Je dirais qu’il faut que tu prennes les fichiers :
                  http://modx.s3.amazonaws.com/assets/fixes/211modxrb/modext-min.js
                  http://modx.s3.amazonaws.com/assets/fixes/211modxrb/modext.js

                  que tu les places dans manager/assets/modext/

                  Que tu modifies manager/controllers/default/browser/index.php comme indiqué dans le commit
                  C’est à dire remplacer la ligne 23 par :
                  MODx.siteId = "'.$_SESSION["modx.{$modx->context->get('key')}.user.token"].'";
                  


                  Qu’ensuite tu mettes le paramètre « compress_js » à « non » (dans les paramètres système) et qu’enfin tu vides les caches (Revo & ton navigateur le cas échéant).

                  Je tenterais certainement l’opération si la 2.1.2-pl ne sort pas dans les jours à venir (joie de la mise en production!)
                  • En faite, je devais juste réaliser la dernière opération:
                    Qu’ensuite tu mettes le paramètre « compress_js » à « non » (dans les paramètres système) et qu’enfin tu vides les caches (Revo & ton navigateur le cas échéant).
                    Cela fonctionne !
                    en attendant une autre mise à jour.
                    Merci.
                      Low
                    • Super merci pour tout vos investigations,
                      J’ai résolu mon problème et j’ai créé un petit blog ici
                      http://www.hello-web.net/fr/blog.html?id=5