On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I have downloaded modx 2.0.0-pl basic revolution.
    and copied it to C:\xampp\htdocs\ folder.
    But whn i try to run http://localhost:100/modx/setup/index.php

    FATAL ERROR: MODx Setup cannot continue.

    To use PHP 5.3.0+, you must set the date.timezone setting in your php.ini. Please do set it to a proper timezone before proceeding. A list can be found here.

    Could anyone suggest what am doing mistake?
      • hi guru,

        add

        php_value date.timezone 'Europe/Berlin'


        to the .htaccess file.
        Worked for me.
        • The (typical) PHP error message you don’t see:

          It is not safe to rely on the system's timezone settings. You are *required* to 
          use the date.timezone setting or the date_default_timezone_set() function. In case you 
          used any of those methods and you are still getting this warning, you most likely misspelled 
          the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead
            lo9on.com

            MODx Evolution/Revolution | Remote Desktop Training | Development
          • Hi folks New to this Forum.

            I tried to set up in my Lion with same problems. set up date/timezone and checked with simple php routine and get timezone as Europe/London, reset Apache but still getting error when trying to initiate setup..

            Any advise would be welcome? [ed. note: alcluith last edited this post 9 years, 3 months ago.]
            • Hi again

              Its the obvious that you miss like not removing the semi-colon to make it active, obvious but can cause you hours of grief

              • alcluith! THANK YOU! I can't believe I missed that.....editing the /etc/php5/apache2/php.ini file's timezone line works just fine for this issue.....gotta remove that semi-colon too! then after restarting apache things should move to the next error...likely adding write access to the cache dir hehe.
                • Hi there,
                  I am trying to do a command line upgrade and I get this fatal error too.
                  I checked my php.ini and the date.timezone setting is ok and not commented (i.e. date.timezone = "Europe/Paris"). And I verified that this php.ini was correctly loaded with phpinfo.

                  I tried to modify the .htaccess with php_value date.timezone 'Europe/Paris' and no luck.

                  I don't undestand since I have done several install with no troubles but this is the first time I tried to do a command line upgrade (which seems to be a great way to do upgrades!).

                  I modified the upgrade xml file and renamed it to config.xml. I did 2 modifications, the path to the core and the language (fr instead of en).
                  And then in the terminal I went to the setup directory and run :

                  php ./index.php --installmode=upgrade


                  I am running Mamp 1.9 with PHP 5.3.2
                  • I did the upgrade via a browser and it worked.

                    Hmm may be it's because when calling php in the terminal I am calling Mac OSX php and not the Mamp's one.
                    • Ok that was that idiot of me!
                      I just looked at MacOSX php and it doesn't have the date.timezone setting activated.