On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • This is a package of Japanese translation files for MODx 0.9.5 laugh
    MODx 0.9.5の翻訳キットを訳したものです。内容は以下のとおりです。
     本体の日本語ファイル
     スニペット ditto、eForm
     プラグイン QuickEdit、Document Manager

    UTF-8、EUC-JP、Shift_JISの3つありますが、UTF-8はすぐ本家配布パッケージに同梱されるでしょう。
    Shift_JISについては完全なチェックを行っていません。動作しなかった場合には是非御報告願います。
    • さっそく試してみました。

      Shift_JISですが、
      Parse error: syntax error, unexpected T_STRING in /home/*****/www/modx/manager/includes/lang/japanese-sjis.inc.php on line 166

      適用直後に上記のように表示され、

      Parse error: syntax error, unexpected T_STRING in /home/*****/www/modx/manager/includes/lang/japanese-sjis.inc.php on line 787

      ブラウザをリロードすると上記のように表示されました。

      UTF-8・EUCは特に問題なかったです。ありがとうございます!
      • EUC版ですが、問題をひとつ見つけました。といっても、今回の翻訳キットに由来する問題ではありませんが。

        ツール→MODx設定→インターフェースとその他の機能の「TinyMCEの設定」まわりが文字化けしています。
        これはTinyMCE用にもともと本体に同梱されているEUC-langファイルの中身の問題のようです。
        • yamaさん。さっそくのお試しありがとうございます。
          line 166 は「表」1字だけというなんとも怪しげな行ですので、表の後に¥を入れてためしていただけませんか?
          TinyMCEの件確認します。

          • 僕が試した時は「表」を「hyou」に書き換えて対応を試みたのですが、状況変わらずでした。
            • MODx0.9.5を同じようにインストールしたサイトで、管理画面が正常に表示されるところと少し乱れるところが
              出てきたので、気になって調べてみました。具体的には添付画像のとおり。



              メントエイリ。アスリンク。みたいな。。

              結論から言うと、当トピックで配布されているlangファイルを適用後にこの状態になります。
              langファイルに問題があるわけではなく、むしろちゃんと翻訳されたlangファイルだったために
              分かったIE独特のレンダリングのバグのように思います。Firefoxでは問題ありません。
              一部の翻訳をわざと中途半端にして、たとえば「リンク属性」を「Link Attributes」に戻すと
              「Attributes」の文字幅ぶんだけ広がります。
              ソースを見ると、ちゃんとtd width=’100’ となっています。
              気になる場合は「manager/actions/mutate_content.dynamic.php」の中の該当個所の
              width=’100’を削除すると、とりあえずそれなりに分かりやすく表示されるようになります。

              ※22時37分追記。
              「<span class="comment" style="width:300px;">」を
              「<span class="comment" style="width:300px;display:block;">」に書き換えるほうが
              正しいです。(CSS的には正しいのか?spanをblockて。 huh)
              「親ドキュメント」の説明文が押し出してしまっている感じです。
              • yamaさん。こんにちは。
                私もその画面のソースをちょっと見てみましたが。。
                ソース自体、違反うんぬんとか始めると泥沼^^;)になりそうなので、
                そこは、見ないふりを。。^^;

                これに関しては、
                「<span class="comment" style="width:300px;">」を
                「<span class="comment" style="width:300px;display:block;">」に書き換えるほうが
                正しいです。(CSS的には正しいのか?spanをblockて。 Huh)
                「親ドキュメント」の説明文が押し出してしまっている感じです。

                もともと、spanはインライン要素で、widthを定義出来ないので、
                そちらが誤りです。
                <span class="comment" style="width:300px;display:block;"
                これは出来ます。

                XHTML 1.1で、tdにwidthを定義するのは違反(だと思った…)なので、それを
                取って表示がうまくいくならば、その方がいいのかもしれません。
                でも、全体を詳しく見ていないので、何とも言えないんですけども。。

                とりあえず、気づいた事を。。
                • EUC-JPバージョンをインストールしました。
                  一見普通に動いていますし、文字化けもないのですが、
                  管理画面で「ツール→MODx設定」画面に移動すると、下記のようなエラーが出てしまいます。

                  TinyMCE - OnInterfaceSettingsRender
                  An error occurred while loading. Please see the event log for more information.

                  Warning: getTinyMCESettings(/usr/home/****/modx/assets/plugins/tinymce2111/lang/japanese-euc.inc.php) [function.getTinyMCESettings]: failed to open stream: No such file or directory in /usr/home/****/modx/assets/plugins/tinymce2111/tinymce.functions.php on line 6

                  Warning: getTinyMCESettings() [function.include]: Failed opening ’/usr/home/****/modx/assets/plugins/tinymce2111/lang/japanese-euc.inc.php’ for inclusion (include_path=’/usr/home/****/modx/manager/includes/’) in /usr/home/****/modx/assets/plugins/tinymce2111/tinymce.functions.php on line 6


                  エラーの下に「OK」ボタンがあるので、クリックすると
                  その後は何事もなかったかのように普通に操作できるのですが・・・。
                  たしかに、Japanese Language Pack for 0.9.5(EUC-JP)の中には
                  /assets/plugins/tinymce2111/tinymce.functions.php
                  に相当するものは入っていないので、エラーが出るのも当然といえば同然の気がします。

                  が、一体じゃあどこからファイルを持ってくればいいのか?がわかりません。
                  どなたかわかる方いらっしゃいましたら、教えていただけないでしょうか。
                  ちなみにサーバーはCPI(Servision)です。

                  ※20:03追記: 
                  ちなみに本体のバージョンは0.9.6です・・・、ってそこがもしや根本的にマズいのでしょうか。。。
                  CPIでは、UTFエンコードだと日本語がことごとく文字化けしてしまうので
                  どうしてもEUC化するしかないのかと思ってトライしています。
                  ややこしくてすみませんですが、どうぞよろしくお願いします。
                  • 初めまして。質問させてください。よろしくお願いします。

                    私もCPI(Servision)を利用しているのでが、shinoiwaさんと同様の現象が起こっています。
                    さらに、スタイルシートとしてドキュメントを作成して保存するときに、
                    ①"ドキュメントエイリアス"の部分が保存されない、
                    ②保存の際に、エラーメッセージが出力される。
                    等の問題が起こっています。

                    WordPressのUTF-8のときもそうでしたが、
                    CPIは文字コードに関することで、トラブルが多く本当に困っています。

                    こちらでもいろいろと調べて見ますが、わかりましたら教えてください。
                    よろしくお願いします。
                    • まずshinoiwaさんへのリプライですが(遅くなってスミマセン。汗)、0.9.6用のeuc-jpファイルは
                      まだ作ってなかったと思います。急いで用意しますので、しばらくお待ちください。