On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • huh

    Hi,

    I’m following step by step for the very 1st time the Revo doc (here : http://rtfm.modx.com/display/revolution20/Installing+a+Package)

    The basic setup (locally on my pc - 2.0.3-pl) was ok but I do not have any extra available.
    There’s 1 provider (modx site), but browsing the extras list, it returns NOTHING, (while telling 103 pages of extras).
    Looking at the provider, /right click, update/, I see an empty API key field .

    What’s going on please?

    thank you

    (I attach screen captures to figure the situation)
      Schtroumpf Grognon - Grouchy Smurf
      ---------------------------------
      Faites pas attention.. - Don't pay attention
      http://www.dzi-neo.net
    • I don’t have an API key either, but it’s working fine. Did you try a browser-cache refresh?
        Sterc Internet & Marketing | MODX Founding Partner | Chairman of the MODX Advisory Board

        In need of a MODX consult? Try our MODX Developers Experts!
      • I work with my FF cache disabled.

        each package list contains "Fournisseur non spécifié" (provider not specified)


        How the hell this thing is supposed to work!?


        Thank you
          Schtroumpf Grognon - Grouchy Smurf
          ---------------------------------
          Faites pas attention.. - Don't pay attention
          http://www.dzi-neo.net
        • Hello

          Are you sure you have cURL enabled ?
          Cheers
          • I’ll check but have no idea of what is curl.
            (standard xamp test lab)
              Schtroumpf Grognon - Grouchy Smurf
              ---------------------------------
              Faites pas attention.. - Don't pay attention
              http://www.dzi-neo.net
            • cURL est une extension PHP. Tu peux l’activer (ou pas) avec Xamp je ne sais pas comment mais sous WAMP (si ça peut t’aider) tu vas sur PHP extensions et tu coches php_curl....
              Cheers

              Sorry for english readers but elz is a french speaker...(as i am)
              • Hi again,

                On my test Xamp (not Wamp) cUrL was not actually active.
                A little bit more tricky to pop it out (a few php.ini files to edit)

                Now my local test is working.

                Thanks a lot I can go further, but is the presence of this very extention could not be tested during setup process ..hmm? any mention about it in the install doc ? (I dont think so embarrassed )

                Merci Anso pour ton assistance aussi.
                  Schtroumpf Grognon - Grouchy Smurf
                  ---------------------------------
                  Faites pas attention.. - Don't pay attention
                  http://www.dzi-neo.net